Closed Bug 1702690 Opened 8 months ago Closed 8 months ago

Refresh the icons of some of the non-default toolbar buttons

Categories

(Firefox :: Toolbars and Customization, task, P1)

task

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox89 --- verified

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-icons])

Attachments

(1 file)

The first round of these is being done in bug 1686527. We're breaking this up over several bugs because some of the new icons aren't available yet.

This bug is concerned with updating the following toolbar button icons (many of which are non-default):

  • The Bookmarks Toolbar button (which represents the bookmarks items in Customize Mode)
  • The Bookmarks Menu button
  • The History button
  • The Add-ons button
  • The Screenshot button
  • The Private Browsing button
  • The Print button
  • The Fullscreen button
  • The Email Link button

Here are items that mstriemer said he doesn't see icons in the Figma for:

  • The Open File button
  • The Screenshot button
  • The Save Page button
  • The Character Encoding button
  • The New Window button
  • The New Tab button
  • The Developer button
  • The Profiler button
  • The Panic button
  • The Cut button
  • The Copy button
  • The Paste button

Hopefully when the later icon batches come in, we'll get these.

rtestard: Since these are icons, I suspect these should be P1.

Flags: needinfo?(rtestard)
Blocks: proton-icons
Whiteboard: [proton-icons]

Also note that the Download button has its own bug - bug 1700238.

Flags: needinfo?(rtestard)
Priority: -- → P1
Severity: -- → S2

We have a https://docs.google.com/document/d/114gLvaDoZpYnhtK_pPGgbMizphBbjrKp23_YHmWHHLE which provides links to where to find the new icon assets, suggested procedure and tracking spreadsheet for icon updates.

Note that some non-default toolbar items may not have newly designed icons, as they were explicitly out of scope. The tracking spreadsheet linked in that doc has those details.

Updates here:

Assignee: nobody → mconley

Reviewing the spreadsheet, I don't see updated icons for:

  • The Bookmarks Toolbar button (which represents the bookmarks items in Customize Mode)
  • The Screenshot button
  • The Email Link button

So I presume these won't make it this round.

I see updated icons, but no spreadsheet entries for:

  • The Bookmarks Menu button
    • chrome://browser/skin/bookmark-star-on-tray.svg (bookmarks-tray.svg)

I have added the Bookmarks Menu button to the spreadsheet. So this bug will update the following icons:

  • The Bookmarks Menu button
    • browser/themes/shared/icons/bookmark-star-on-tray.svg (bookmarks-tray.svg)
  • The Add-ons button
    • toolkit/themes/shared/extensions/extension.svg (extension-fill.svg)
  • The Private Browsing button
    • browser/themes/shared/icons/privateBrowsing.svg (private-mode-fill.svg)
  • The Fullscreen button
    • browser/themes/shared/icons/fullscreen.svg (fullscreen-expand.svg)

The fullscreen button icon is also shared with the AppMenu, so I'm going to land that one separately in bug 1693856.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dd37bbc8c2ae
Update some non-default toolbar button icons. r=sfoster
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Verified that the Icons for the listed buttons in Comment 5 are implemented and looking/working correctly. Tests were performed on Firefox 89.0a1 (2021-04-14) under macOS 11.2.3, Ubuntu 20.04 and Windows 10.

Status: RESOLVED → VERIFIED
Regressions: 1705347
Depends on: 1707950
You need to log in before you can comment on or make changes to this bug.