Closed Bug 170396 Opened 18 years ago Closed 16 years ago

ebay.com / passport blocks Mozilla users from authenticating

Categories

(Tech Evangelism Graveyard :: English US, defect, P1, major)

x86
All

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: wolruf, Unassigned)

References

()

Details

(Whiteboard: [user agent])

Build ID: 2002092304 Win2k (trunk).

Steps to reproduce (you don't need any ebay or passport account to reproduce bug):
1. Load URL http://cgi1.ebay.com/aw-cgi/eBayISAPI.dll?MyEbayLogin
2. Click on Passport login (bottom of page),
3. See the error: passport is unavailable (after requesting data from
msauth.ebay.com)

Same thing works fine using IE6 and NS4.8.
I believe it's a Tech Evangelism issue although it could also be a timeout issue
very specific to Mozilla (and Gecko-based browser, also tried Phoenix with a
default configuration, accepting cookies). I have tried both settings 'enable
all cookies' as I usually only 'enable cookies from originating sites'.

There was another bug report (now fixed) about passport/hotmail blocking mozilla
users to register: bug 141279.
Keywords: evang500
WFM with Gecko/20020823 Netscape/7.0 

Checking if this is a dupe of bug 156725 
wfm using Phoenix 20021020 Win2k.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
*** Bug 187352 has been marked as a duplicate of this bug. ***
don't work for me. Moz 2003010908/win98
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
confirm works in ns 7.01 with ns 7.01 ua but not in ns 7.01 with a mozilla ua.
Blocks: MS
Whiteboard: [user agent]
build 2003010308
This bug was not present in earlier releases: try these
1. connect to a microsoft ".net password". attempt to disconnect : no way
2. go to this url 
http://members.msn.com/find.msnw
check "Include adult profiles in search results"
		This option requires signing in with a .Net Passport
click search/ next page click "i agree"
the page reloads itself
3. retry step. 1
4. it costed me 5 cents:
go to this URL:
http://cgi.ebay.fr/ws/eBayISAPI.dll?ViewItem&item=2300118409&ssPageName=ADME:B:LC:FR:1
try to put a bid on the "object"
5. retry step 1.
is that a microsoft cabale?
don't work with 2003010923 too
Blocks: 187236
mine
Assignee: aruner → bclary
Status: REOPENED → NEW
howto:
Change your preferences in e-bay *not to* use micro$oft pa$$word to login to e-bay
should be enough (to be verified)
No longer blocks: 187236
Depends on: 187236
contacted and they are looking into the issue.
Status: NEW → ASSIGNED
Target Milestone: --- → Feb
Severity: critical → major
Priority: -- → P1
still bad.->mar
Target Milestone: Feb → Mar
tech evang june 2003 reorg
Component: US Ecommerce → English US
Target Milestone: Mar → ---
->default
Assignee: bc → english-us
Status: ASSIGNED → NEW
QA Contact: bc → english-us
wfm FB 20031227 Win2k.
Status: NEW → RESOLVED
Closed: 18 years ago16 years ago
Resolution: --- → FIXED
*** Bug 210997 has been marked as a duplicate of this bug. ***
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.