Closed Bug 1704163 Opened 8 months ago Closed 8 months ago

Proton context menu reftest perma failure - TEST-UNEXPECTED-FAIL | layout/reftests/xul/menulist-shrinkwrap-2.xhtml == layout/reftests/xul/menulist-shrinkwrap-2-ref.xhtml | image comparison, max difference: 237, number of differing pixels: 87

Categories

(Firefox :: Theme, task)

task

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox89 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-context-menus])

Attachments

(1 file)

The failure is caused by this rule here: https://searchfox.org/mozilla-central/rev/3ae6f9e4444f3fbf61034317540d36f621117600/toolkit/themes/windows/global/popup.css#45-49

So I guess the extra padding causes string cropping in the menulist element when the parent vbox has align="start"?

I recommend we just disable Proton contextmenus for this reftest for now, and file a cleanup bug to figure out the actual right move here.

Blocks: 1704174

Copying from phab: Seems ok to disable for now, but the relevant bug / code is bug 623922, and if that is getting cropped, it seems like a bug in the menupopup sizing code touched in that bug.

So watch out for menulists that might not shrinkwrap properly.

See Also: → 623922
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3a4f4d99eb21
Disable Proton for the menulist-shrinkwrap-2.xhtml XUL reftest. r=emilio
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
You need to log in before you can comment on or make changes to this bug.