If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

OS/2 disappeared from 'Operating System' list

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Creating/Changing Bugs
--
major
RESOLVED FIXED
15 years ago
5 years ago

People

(Reporter: Max Alekseyev, Assigned: gerv)

Tracking

2.10
Bugzilla 2.18
x86
OS/2

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.2b) Gecko/20020919
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.2b) Gecko/20020919

I've just discovered that OS/2 disappeared from 'Operating System' list.
What's wrong?


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
I mean the list offered on creating bug through Bugzilla Helper.
Component: Bugzilla-General → Administration
(Reporter)

Updated

15 years ago
Component: Administration → Creating/Changing Bugs

Comment 2

15 years ago
cute, half of the platforms aren't in
http://bugzilla.mozilla.org/enter_bug.cgi?product=Bugzilla&format=guided
Assignee: justdave → gerv
OS: other → OS/2
(Assignee)

Comment 3

15 years ago
This is by design. That form has been made simpler by eliminating less common
cases. You can always set your OS to "Other" and a QA person will set it
correctly. Or, you can use the standard form.

Gerv
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 4

15 years ago
Sorry Grev, but I would wager OS/2 has just as many users as FreeBSD or sunOS.

That's not a good argument.

Why not make the field a LOT more intelligent? Like have a very small list to
select from, but allow autodetection of any operating system.

The "other" assignment is a REAL pain as it can cause OS/2 bugs to be lost for
many weeks (which has happened)

Comment 5

15 years ago
*** Bug 166277 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

15 years ago
> Why not make the field a LOT more intelligent? Like have a very small list to
> select from, but allow autodetection of any operating system.

That sounds like a very good idea. And I think I know how we can do it really
easily. I'll look at implementing that ASAP.

Gerv
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Comment 7

15 years ago
This is how you do it. Change the block which produces those select menus so
that if there's a default, it's automatically included even if it's not in the
list. The defaults are set using detection in enter_bug.cgi.

This will allow us to simplify by removing more of the minority OSes from the
list, too, because they will be caught by this mechanism.

+[% BLOCK select %]
+  <select name="[% sel %]">
+    [%- FOREACH x = $sel %]
+      <option value="[% x FILTER html %]"
+        [% " selected=\"selected\"" IF x == default.$sel %]>
+        [% x FILTER html -%]
+      </option>
+    [%- END %]
+  </select>
+[% END %]

->

+[% BLOCK select %]
+  <select name="[% sel %]">
+    [%- IF default.$sel %]
+      <option value="[% default.$sel FILTER html %]" selected="selected">
+        [% default.$sel FILTER html -%]
+      </option>
+    [% END %]
+    [%- FOREACH x = $sel %]
+      [% NEXT IF x == default.$sel %]
+      <option value="[% x FILTER html %]">
+        [% x FILTER html -%]
+      </option>
+    [%- END %]
+  </select>
+[% END %]

I'll make a proper patch soon; I hope to get the Helper checked into Bugzilla
itself as example code (bug 171770). That'll make it easier to fix.

Gerv
(Assignee)

Updated

15 years ago
Depends on: 171770
Gerv, was this fixed by the checking on bug 171770?
(Assignee)

Comment 9

15 years ago
Created attachment 103905 [details] [diff] [review]
Patch v.1

This should do the trick.

Gerv
(Assignee)

Comment 10

15 years ago
Dave: nope :-) I checked in the Helper exactly as it's being used on b.m.o.,
except with the change you suggested. I've just added a patch here to solve the
reported problem.

Gerv
(Assignee)

Updated

15 years ago
Blocks: 176570
No longer blocks: 176570
(Assignee)

Comment 11

15 years ago
I'm afraid this didn't make the b.m.o. upgrade train - I was pushing for it, but
no-one was able to find time to review the patch :-(

Gerv
Comment on attachment 103905 [details] [diff] [review]
Patch v.1

r=justdave
a=justdave
Attachment #103905 - Flags: review+
(Assignee)

Comment 13

15 years ago
myk: can I persuade you to CVS update
template/en/default/bug/create/create-guided.html.tmpl ? :-)

Fixed.

Checking in template/en/default/bug/create/create-guided.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/create-guided.html.tmpl,v
 <--  create-guided.html.tmpl
new revision: 1.2; previous revision: 1.1
done


Gerv
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18

Comment 14

15 years ago
This isn't working.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Version: unspecified → 2.10
restoring fixed state.  bugzilla.mozilla.org has not yet upgraded since this was
checked in.  If it's still broken after b.m.o updates, then you can reopen.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

14 years ago
*** Bug 227165 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.