Open Bug 1705041 Opened 3 years ago Updated 1 year ago

Week number display in Month/Multiweek views is confusing - should have separate week column

Categories

(Calendar :: Calendar Frontend, enhancement)

Thunderbird 78
enhancement

Tracking

(Not tracked)

People

(Reporter: sknorr.os, Unassigned)

References

(Depends on 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:87.0) Gecko/20100101 Firefox/87.0

Steps to reproduce:

In Lightning's Month and Multiweek views, week numbers are displayed on the left side of the header of the leftmost day. Unfortunately, the right side of those day headers also contains a number (day of the month). I.e., it looks something like this:

14 5| 6| 7| 8| ...

Actual results:

Both numbers are unprefixed which makes it very easy to confuse them for another, the only difference between them is that the week number is displayed in a lighter gray.

Expected results:

Please make it harder to confuse the numbers. Elsewhere in the UI, week numbers are already prefixed with "CW", so I think that would make most sense here too.
To pick up my example from above, a display like this would help me a lot:

CW14 5| 6| 7| 8| ...

Component: General → Calendar Frontend

Yes, or just Week

Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2

Of course, it's quite a hack to have the week number in that place to begin with. That's not how calendars usually (or ever?) display them. It should be closer to attachment 8485517 [details].

May end up as a dupe of bug 1715600.

See Also: → 1715600

Let's morph this to be about having a separate week column instead, like almost all other calendars do.

Summary: Week number display in Month/Multiweek views is confusing → Week number display in Month/Multiweek views is confusing - should have separate week column

I can add the column after bug 1738689

Assignee: nobody → henry
Status: NEW → ASSIGNED
Depends on: 1738689
Assignee: henry → nobody
Status: ASSIGNED → NEW

In the case you guys going to fix this.... can you make it possible, that when in the calendar the week numbers are visible in the month overview, they also being printed in-front of the weeks ?
thank you.

See Also: → 1811358

The week numbers are prefixed and colored due to bug 1816485 so I don't think this needs any further changes.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
See Also: → 1816485

This bug is about having it as a column, like all paper calendars and other online calendars reasonably have. E.g. google calendar, microsoft365.
To quote my wife: "Where are the week numbers, I can't use this calendar!" ;)

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → NEW
Priority: P2 → --
You need to log in before you can comment on or make changes to this bug.