Closed Bug 1706047 Opened 2 months ago Closed 2 months ago

The font of the “Learn more” link in the “Import Error” modal seems thicker than it should be

Categories

(Firefox :: about:logins, defect)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox88 --- unaffected
firefox89 --- disabled
firefox90 --- verified

People

(Reporter: mheres, Assigned: anshukaira)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached image new Learn more.png

[Affected Versions]:

  • Firefox Nightly 89.0a1 (Build ID: 20210418213620)

[Affected Platforms]:

  • Linux Mint 20
  • Windows 10
  • macOS 11.1

[Prerequisites]:

  • Have Firefox open.
  • From the “about:config” page, have signon.management.page.fileImport.enabled set to true.
  • Have a CSV file containing login data for which the header row has been deleted.

[Steps to reproduce]:

  1. Navigate to “about:logins”.
  2. Click the meatball menu button (“...”).
  3. Choose the “Import from a File...” option.
  4. Choose a CSV file without a header and import it.
  5. Observe the text of the “Import Error” modal.

[Expected result]:

  • The font of the “Learn more” link is slightly thinner.

[Actual result]:

  • The font of the “Learn more” link seems to now be slightly thicker than it should be compared to the documentation.

[Notes]:

  • Attached is a screenshot of the issue compared to the documentation.

Hy. I was working on this and thought I should take it to the end (well if possible)

Last time in Bug 1701689 we added a class and made its weight bold which was normal earlier.
But it seems that it becomes thicker than it is supposed to be. What font-weight would you suggest?

Apart from this -- if we see in the dialog box I think the heading File format Issue -> its weight is also thicker than in the documentation.
A similar kind of thing happens in the other two dialog box in the documentation

Thanks.

Flags: needinfo?(sfoster)

Hey Kaira, since it seems like we need to split the distance between normal and bold, we need to use a semi-bold (or demi-bold). For reference, here are the common font weight name mappings so font-weight: 600 should work in this case.

Flags: needinfo?(sfoster)

ohk. 600 it is.
so please assign me this issue as well. thanks
what about other import boxes and the heading i mentioned about?
shouldn't we change those too.

Flags: needinfo?(tgiles)

Hi Kaira, go ahead and fix the (I'm assuming) font weight on the "View detailed Import Summary" link as well as the "File Format Issue" weight. Thanks!

Assignee: nobody → anshusinghjsk
Status: NEW → ASSIGNED
Flags: needinfo?(tgiles)
Attachment #9216903 - Attachment description: Bug 1706047 changes font-weight for CSV error & summary dialog. r=tgiles → Bug 1706047 changes font-weight for link in CSV error & summary dialog. r=tgiles
Attachment #9216903 - Attachment description: Bug 1706047 changes font-weight for link in CSV error & summary dialog. r=tgiles → Bug 1706047 change font-weight for link in CSV error & summary dialog. r=tgiles
Attachment #9217190 - Attachment is obsolete: true
Pushed by tgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7e86b3acfc33
change font-weight for link in CSV error & summary dialog. r=tgiles
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

I have verified that the "Learn more" and "File Format Issue" texts from the "Import Error" modal and the "View detailed Import Summary" text from the "Import Complete" modal have been changed to weight 600 (observed using the Inspector tool). Tested on Firefox Nightly 90.0a1 (Build ID: 20210422093115) using Windows 10, Linux Mint 20 and macOS 11.1.

Visually, on Windows 10, the implementation seems almost if not perfectly true to the documentation; on Linux Mint 20, the change from bold to demi-bold doesn't seem noticeable on my system; on macOS 11.1 the font seems slightly bolder than on the other 2 platforms (which was always the case), but the change is observable (the current state being similar to the one observed on Linux Mint).

Status: RESOLVED → VERIFIED

The patch landed in nightly and beta is affected.
:anshukaira, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(anshusinghjsk)

hi :tgiles
umm, there is a need info flag for me but I don't quite understand what it means.
I visited auto_nag documentation mentioned in above comment

It seems I have to tell them that is it ok to push it for the beta version???

Do I need to reply it like :

Comment on attachment [Comment 10](https://bugzilla.mozilla.org/show_bug.cgi?id=1706047#c10)
Bug XXX - description
Beta/Release Uplift Approval Request

    User impact if declined: Spacer sizing is off in the navbar in customize mode
    Is this code covered by automated tests?: ?
    Has the fix been verified in Nightly?: ?
    Needs manual test from QE?: ?
    If yes, steps to reproduce:
    List of other uplifts needed: 
    Risk to taking this patch: Low
    Why is the change risky/not risky? (and alternatives if risky): Small CSS fix
    String changes made/needed: 

Took abv from this Bug Comment

I really don't have any idea. Thanks :)

Flags: needinfo?(tgiles)

Hi Kaira, thanks for bringing this to my attention. (Accidentally submitted my comment half-finished). There's nothing you need to do about the auto-nag bot, since we don't need to uplift this patch to beta.

Flags: needinfo?(tgiles)
Flags: needinfo?(anshusinghjsk)

ohh okk! thanks a lot.

You need to log in before you can comment on or make changes to this bug.