Closed Bug 1706143 Opened 1 year ago Closed 8 months ago

Bookmarks Toolbar set to never show but still pops up when adding a new bookmark

Categories

(Firefox :: Bookmarks & History, defect, P2)

Firefox 87
Unspecified
All
defect

Tracking

()

VERIFIED FIXED
94 Branch
Tracking Status
firefox87 --- wontfix
firefox88 --- wontfix
firefox89 --- wontfix
firefox90 --- wontfix
firefox94 --- verified

People

(Reporter: maybeoneday+bugzilla, Assigned: mkohler)

References

Details

(Keywords: papercut)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

  1. Set Bookmarks Toolbar to Never Show.
  2. Bookmark a webpage selecting Bookmarks Toolbar as Folder.

Actual results:

Bookmarks Toolbar pops up at the top.

You don't even need to hit Done. As soon as Bookmarks Toolbar is selected in the Folder dropdown, it pops up.

Expected results:

Bookmarks Toolbar doesn't pop up.

The Bugbug bot thinks this bug should belong to the 'Firefox::Bookmarks & History' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Bookmarks & History

The issue is reproducible on all versions since Firefox 87 so I'm setting the flags and its status as "NEW"

Thank you for reporting!

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All

I think the toolbar is shown temporarily to show the bookmark destination, as soon as I move to another tab it goes away.
Does the toolbar persist for you?

Flags: needinfo?(maybeoneday+bugzilla)

Oh you're right it doesn't actually persist after leaving the tab haha. My bad. And here I am deactivating it through the context menu every time this happens.

Flags: needinfo?(maybeoneday+bugzilla)

Still though, why have it pop up? You don't do it for any other folder. Not to mention I already know the destination (since I just chose it myself).

yes, I think it's confusing, but I'm not sure if there's a way to distinguish when the user made an explicit choice about the toolbar rather than it being the default hidden state? Gijs, what's the expected outcome we wanted? I think we should not be showing the toolbar temporarily.

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to Marco Bonardo [:mak] from comment #6)

yes, I think it's confusing, but I'm not sure if there's a way to distinguish when the user made an explicit choice about the toolbar rather than it being the default hidden state? Gijs, what's the expected outcome we wanted? I think we should not be showing the toolbar temporarily.

To me this feels like something where we should defer to UX. I don't have a strong opinion. I can definitely see why as a user who is very familiar with how bookmarks work and really doesn't want to see the toolbar, this could be annoying.

OTOH, adding inconsistency by showing the toolbar only the first time or only if you haven't manually chosen the toolbar when the default folder was something else, adds implementation complexity and will probably cause confusion for less-expert users (ie why isn't it showing the toolbar now? But it shows it for the next bookmark (where the default was already the toolbar, because it changed after the previous bookmark being put there)?). Having just triaged bug 1709107 which includes some expert users being confused about not being offered options that make no sense in their situation (manually restoring a session when that already happened automatically), I am not sure that trying to be "clever" here will really fix anything.

No longer showing the toolbar at all removes feedback the first time the user bookmarks, which also doesn't seem great. So, I don't really know that there's a simple solution here...

Jared, do you recall who did the UX work for this so we can ask them?

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(jaws)

(In reply to :Gijs (he/him) from comment #7)

OTOH, adding inconsistency by showing the toolbar only the first time or only if you haven't manually chosen the toolbar when the default folder was something else, adds implementation complexity and will probably cause confusion for less-expert users (ie why isn't it showing the toolbar now? But it shows it for the next bookmark (where the default was already the toolbar, because it changed after the previous bookmark being put there)?).

I don't think so.
A less expert user will likely just stick to the initial state anyway, that means if they never add to the toolbar it stays not visible, if they add to it it stays visible (until an explicit choice is made, but less expert users are unlikely to do that).
A more expert user will probably make a choice about the toolbar state, either immediately of after the first time they add to the toolbar and we show it, and that choice should stick.

Here the problem is that the user made a choice and we temporarily break it. This is very confusing.

(In reply to :Gijs (he/him) from comment #7)

Jared, do you recall who did the UX work for this so we can ask them?

Katie was in charge here. I asked her and she said "If someone actively chooses “Never Show” - we should respect that and never show it".

Flags: needinfo?(jaws)

Setting as a P2 because it seems annoying and confusing for the users.
Patches or mentoring are welcome of course.

Severity: -- → S3
Keywords: papercut
Priority: -- → P2
Duplicate of this bug: 1713471
Duplicate of this bug: 1717948
Assignee: nobody → me
Status: NEW → ASSIGNED
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/572629526eed
Do not show bookmark toolbar when creating/editing bookmark if set to never be shown r=Standard8
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Duplicate of this bug: 1714408
Flags: qe-verify+

I've verified the fix on Firefox 94.0b2

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.