Closed Bug 1706379 Opened 3 years ago Closed 3 years ago

(Proton) (regression) Site identity panel animation is no longer smooth

Categories

(Firefox :: Site Identity, defect, P2)

Firefox 90
defect

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- unaffected
firefox89 --- wontfix
firefox90 --- fixed

People

(Reporter: soeren.hentzschel, Assigned: emmamalysz)

References

(Regressed 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [proton-door-hangers][priority:2a])

Attachments

(3 files)

Attached video screencast

Since the landing of the new identity panel style the animation when navigating from the subpanel back to the main panel is no longer smooth, the footer row for deleting cookies and website data jumps. Please see the attached video.

Set release status flags based on info from the regressing bug 1703012

Is this a dupe of 1692519?

Flags: needinfo?(mconley)
Priority: -- → P2
Whiteboard: [proton-door-hangers] → [proton-door-hangers][priority:2a]

I don't think so... it looks less like a graphics glitch, and more like we're applying some kind of CSS rule after the animation completes rather than before. So I think this is separate.

Flags: needinfo?(mconley)

I ran mozregresssin in order to find out what broke this, and it seems that one of the patches from this pushlog is the culprit. Emma, would you mind taking a look at this?

changeset: ac952451dc017a284361b54e1390b29e4cb8f3fa
pushlog_url: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ac952451dc017a284361b54e1390b29e4cb8f3fa&tochange=14f7b86bc41ad55974a1b10a21c93d1cdb9d12e4

Flags: needinfo?(emalysz)
Assignee: nobody → emalysz
Status: NEW → ASSIGNED
Flags: needinfo?(emalysz)
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5aef1459fece
improve site identity css rules for smooth animation r=mconley
See Also: → 1708819
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

The fix does not work at all, at least not on macOS. The behaviour seems to be exactly the same as without the patch.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Emma, could you please take another look? Thanks!

Severity: -- → S4
Flags: needinfo?(emalysz)
Flags: needinfo?(emalysz)

Hi Sören, are you still seeing this issue on the current nightly build? I attached a video of the improved experience I'm seeing on macOS. Note the icon overlap should be addressed in Bug 1709106

This patch is treated as a CSS band-aid to alleviate some of the bumpiness in the transition, so I don't think it perfectly addresses the issue. However, I think we should use Bug 1708819 to fix the root cause of the problem and uplift this, as I think it's an improvement from the first video.

Flags: needinfo?(soeren.hentzschel)

Yes, for me it still looks exactly the same as in the video that was attached in the original report. I can reproduce this on two different devices, both devices have the same configuration.

Device: MacBook Pro Late 2018, 2,6 GHz 6-Core Intel Core i7, 16 GB 2400 MHz DDR4
OS: macOS 11.3
Firefox Build: Nightly build from 2021-05-03.

Flags: needinfo?(soeren.hentzschel)

Hi Sören, thanks for providing all of this info! We're going to handle the fix for the issue you're still seeing in Bug 1708819 and close out this particular bug. While the patch doesn't address the issue you're encountering, it does seem to improve the experience for other users, so it's a net win for now.

Tyler or Romain, is it safe to uplift this patch? It doesn't look like any regressions have been filed, and it landed a couple of days ago

Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Flags: needinfo?(tduzan)
Flags: needinfo?(rtestard)
Resolution: --- → FIXED

Hi Emma, I'm not clear on what the patch fixes in terms of user experience. The video shows the overlap issue raised on bug 1709106 - is this a regression introduced by the patch?
At this stage we'll only want to uplift icon changes and bugs identified as P1s to avoid introduction of new regressions so this one feels like it should track 90 along with Bug 1708819.

Flags: needinfo?(rtestard)
Regressions: 1709712

Howdy Emma, can you reply to Romain's question above? On initial reading, I thought this may be related to other issues with panel animations, but I'm not actually sure what was fixed in this bug vs what was broken out.

Thanks

Flags: needinfo?(tduzan) → needinfo?(emalysz)

This patch reduced the jerky animation on some devices, so I figured the non-zero impact was worth uplifting. Comparing the two videos, there's less of a jump on the "Clear cookies" footer.

This bug did not introduce the regression we see in bug 1709106, but it looks lie there's a patch up to handle that case. Since there's still a bug associated with the panel animation that will be handled in Bug 1708819, perhaps we're better off letting this ride the trains of release

Flags: needinfo?(emalysz)

Thanks, marking this bug now as "won't fix" for 89

Regressions: 1712847
Regressions: 1725643
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: