Closed Bug 1706849 Opened 5 months ago Closed 3 months ago

Reordering accounts in the Account Settings tab is broken

Categories

(Thunderbird :: Account Manager, defect)

Thunderbird 90
defect

Tracking

(thunderbird_esr78 unaffected, thunderbird91+ fixed)

RESOLVED FIXED
91 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird91 + fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

(Keywords: regression)

Attachments

(1 file)

Dragging and dropping an account to reorder it always puts the dragged account at the top of the list. There's also no drag position indicator showing.

It seems to be working, but yeah no indicator (I think we never got that working).
That it refreshes the whole tree on drop gives some bad ux. See bug 1703501 as well.

See Also: → 244347
Version: unspecified → Thunderbird 90

I can't confirm the "always at the top of the list" behavior. The way the code works iirc is that it puts the dragged account to the position of the hovered account and pushes the hovered account down.

See also bug 1709370 and bug 1708283.

See Also: → 1703501
Assignee: nobody → geoff
Status: NEW → ASSIGNED

The code to determine the dropped position didn't account for collapsed rows. While here I added a marker to show where a drop would occur.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/da5dbce71dfb
Fix reordering accounts by drag-n-drop in the Account Settings tab. r=freaktechnik

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Blocks: 1721761
You need to log in before you can comment on or make changes to this bug.