Closed Bug 1707086 Opened 7 months ago Closed 7 months ago

Update browser/themes/shared/controlcenter/ icons for Proton

Categories

(Firefox :: Theme, task)

task

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox89 --- verified
firefox90 --- verified

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-icons] [proton-uplift])

Attachments

(1 file)

Despite the name, due to historical reasons, these icons tend to show up in the Protections Panel, and not in the Control Center.

These icons are:

  • browser/themes/shared/controlcenter/socialblock-disabled.svg (social-tracker-blocked.svg)
  • browser/themes/shared/controlcenter/cryptominers-disabled.svg (cryptominer-blocked.svg)
  • browser/themes/shared/controlcenter/socialblock.svg (social-tracker.svg)
  • browser/themes/shared/controlcenter/3rdpartycookies-disabled.svg (tracking-cookies-blocked.svg)
  • browser/themes/shared/controlcenter/fingerprinters.svg (fingerprinter.svg)
  • browser/themes/shared/controlcenter/trackers.svg (footprints.svg)
  • browser/themes/shared/controlcenter/cryptominers.svg (cryptominer.svg)
  • browser/themes/shared/controlcenter/tracker-image-disabled.svg (canvas-blocked.svg)
  • browser/themes/shared/controlcenter/tracker-image.svg (canvas.svg)
  • browser/themes/shared/controlcenter/tracking-protection.svg (shield-20.svg)
  • browser/themes/shared/controlcenter/3rdpartycookies.svg (tracking-cookies.svg)
  • browser/themes/shared/controlcenter/warning.svg (warning-fill.svg)
  • browser/themes/shared/controlcenter/fingerprinters-disabled.svg (fingerprinter-blocked.svg)
Assignee: nobody → mconley
Blocks: 1707101
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/398a45d11379
Update Protections Panel icons for Proton. r=sfoster
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Comment on attachment 9217889 [details]
Bug 1707086 - Update Protections Panel icons for Proton. r?sfoster!

Beta/Release Uplift Approval Request

  • User impact if declined: Required for MR1 / Proton
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Asset swap for new icons for Proton.
  • String changes made/needed: None.
Attachment #9217889 - Flags: approval-mozilla-beta?
Whiteboard: [proton-icons] → [proton-icons] [proton-uplift]

Comment on attachment 9217889 [details]
Bug 1707086 - Update Protections Panel icons for Proton. r?sfoster!

Approved for 89 beta 6, thanks.

Attachment #9217889 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hi, I'm trying to verify this issue, all the icons mentioned in the description but I can't seem to find the Disabled ones, the ones that are suppose to be crossed off, Molly can you please take a look at this ?

socialblock-disabled.svg
cryptominers-disabled.svg
3rdpartycookies-disabled.svg
tracker-image-disabled.svg
fingerprinters-disabled.svg

Also if someone has a Test page that has all types of cookies or something similar it would help us a lot. Thanks

Flags: needinfo?(mhowell)

I've done some research and I'm convinced that we are no longer using these five icons. They appear to have been removed from the UI the last time that the protections panel was redesigned, in bug 1572528. We used to display one of these "disabled" icons in the subpanels that list out blocked items, next to the name of each blocked item in the list. As you've seen, there are now no icons next to those items; they were kind of redundant, so removing them to reduce clutter does seem to make sense.

It looks like what we should do then is file a new icon cleanup bug to remove these icons and the (also unused) CSS referencing them. I'll do that and link it here.

Flags: needinfo?(mhowell)
See Also: → 1719370

Since the Disabled ones are being removed in Bug 1719370 I can confirm that this issue is Verified as Fixed in Firefox 89.0.2 as well as our latest Release version 90.0 on Windows, Mac and Ubuntu.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.