Closed Bug 1707141 Opened 2 months ago Closed 2 months ago

[win7] Remove theme screen from upgrade onboarding

Categories

(Firefox :: Messaging System, enhancement, P2)

Unspecified
Windows 7
enhancement

Tracking

()

VERIFIED FIXED
90 Branch
Iteration:
90.1 - Apr 19 - May 2
Tracking Status
firefox89 --- verified
firefox90 --- verified

People

(Reporter: Mardak, Assigned: Mardak)

References

(Blocks 1 open bug)

Details

(Keywords: perf-alert, Whiteboard: [proton-onboarding] [proton-uplift] [priority:2a])

Attachments

(4 files)

To avoid bug 1702480, don't have upgrade users pick a theme.

Still pending final designs for what the first screen buttons should be if Firefox is already the default (as normally it shows a button mentioning themes). We can reuse "Okay" cfr-doorhanger-doh-primary-button-2 from newtab/asrouter.ftl as the only button (no "Not now").

Steps indicator should not be shown as there's only one step.

Assignee: nobody → edilee
Priority: -- → P1
Iteration: --- → 90.1 - Apr 19 - May 2
Whiteboard: [proton-onboarding]

Detect old windows version to change content reusing an asrouter "Okay" string for now.

No longer depends on: 1707140
Blocks: 1708056
Attached image already default
Attached image not default
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/48f696159514
[win7] Remove theme screen from upgrade onboarding r=pdahiya
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Comment on attachment 9218784 [details]
Bug 1707141 - [win7] Remove theme screen from upgrade onboarding r=pdahiya

Beta/Release Uplift Approval Request

  • User impact if declined: Upgrading windows 7 users see a theme selection screen making bug 1702480 more common
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Set browser.startup.homepage_override.mstone to "88.0"
  1. Make sure browser.startup.upgradeDialog.version is cleared
  2. Restart Firefox
  3. See windows-7 single screen upgrade dialog
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Slight behavior change removing the second upgrade screen for windows 7
  • String changes made/needed: no new strings by reusing an existing one
Attachment #9218784 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]
Whiteboard: [proton-onboarding] → [proton-onboarding] [proton-uplift]

I have verified this enhancement and I can confirm the following:

  • The "Make Firefox my default browser" modal is displayed if the browser is not set as default.
  • The "Okay" modal is displayed if the browser is set as default.
  • The "Themes" modal is not displayed regardless if the browser is set as default or not.

Verified using the latest Firefox Nightly (90.0a1 - Build ID: 20210428100720) installed on Windows 7 x64.

Status: RESOLVED → VERIFIED

Comment on attachment 9218784 [details]
Bug 1707141 - [win7] Remove theme screen from upgrade onboarding r=pdahiya

Approved for 89 beta 6, thanks.

Attachment #9218784 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Backed out changeset 48f696159514 (Bug 1707141) for causing bc failures in browser_browserGlue_upgradeDialog.js
Backout link: https://hg.mozilla.org/integration/autoland/rev/abbe74ed15352292ef6f6b617f7b27ddc1ac27bd
Push with failures, failure log.

Status: VERIFIED → REOPENED
Flags: needinfo?(edilee)
Resolution: FIXED → ---
Target Milestone: 90 Branch → ---

This is a separate test-only followup for easier uplift.

Attachment #9218784 - Attachment description: Bug 1707141 - [win7] Remove theme screen from upgrade onboarding r?pdahiya → Bug 1707141 - [win7] Remove theme screen from upgrade onboarding r=pdahiya

I've fixed the win7 bc test failure and relanding to autoland. I'll request uplift of attachment 9219122 [details] test-only fix for beta with r+ and when autoland is green.

Flags: needinfo?(edilee)
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ba8c82320e1
[win7] Remove theme screen from upgrade onboarding r=pdahiya
See Also: → 1706830

Backout merged to central: https://hg.mozilla.org/mozilla-central/rev/abbe74ed1535

Push from comment 10 will be merged to central later on.

Priority: P1 → P2
Whiteboard: [proton-onboarding] [proton-uplift] → [proton-onboarding] [proton-uplift] [priority:2a]
Severity: -- → S3
Priority: P2 → P1
Priority: P1 → P2

not sure if switching to P2 is intended, changing to P2 in favor of Proton team bugs tracking

Comment on attachment 9219122 [details]
Bug 1707141 - Mock AppConstants during most of upgradeDialog test to avoid win7-specific failures r?pdahiya,andreio

Beta/Release Uplift Approval Request

Windows 7 opt bc2 and debug bc6 are green and ran the beta-failing browser_browserGlue_upgradeDialog.js

  • String changes made/needed: none
Attachment #9219122 - Flags: approval-mozilla-beta?
Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Comment on attachment 9219122 [details]
Bug 1707141 - Mock AppConstants during most of upgradeDialog test to avoid win7-specific failures r?pdahiya,andreio

Approved for beta, thanks.

Attachment #9219122 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified this enhancement and I can confirm the following:

  • The "Make Firefox my default browser" modal is displayed if the browser is not set as default.
  • The "Okay" modal is displayed if the browser is set as default.
  • The "Themes" modal is not displayed regardless if the browser is set as default or not.

Verified using the latest Firefox Beta (89.0b7 - Build ID: 20210502185943) installed on Windows 7 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

== Change summary for alert #29965 (as of Wed, 05 May 2021 04:16:02 GMT) ==

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
18% amazon-search fnbpaint android-hw-g5-7-0-arm7-api-16-shippable warm 905.79 -> 740.12
18% amazon-search fcp android-hw-g5-7-0-arm7-api-16-shippable warm 875.77 -> 722.00
16% bbc SpeedIndex android-hw-p2-8-0-android-aarch64-shippable-qr warm webrender 599.67 -> 503.08
16% amazon-search FirstVisualChange android-hw-g5-7-0-arm7-api-16-shippable warm 1,149.33 -> 965.08
14% amazon-search FirstVisualChange android-hw-p2-8-0-android-aarch64-shippable-qr warm webrender 496.04 -> 424.75
... ... ... ... ... ...
8% booking PerceptualSpeedIndex android-hw-g5-7-0-arm7-api-16-shippable-qr warm webrender 2,515.88 -> 2,314.83

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=29965

Keywords: perf-alert

The perf alert should probably be for bug 1697215

Blocks: 1710460
You need to log in before you can comment on or make changes to this bug.