Closed Bug 1707273 Opened 2 years ago Closed 2 years ago

Mail header fields unreadable on macOS w/ dark mode

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 89
x86_64
macOS
defect

Tracking

(thunderbird_esr78 unaffected, thunderbird89+ verified)

VERIFIED FIXED
90 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird89 + verified

People

(Reporter: rjl, Assigned: aleca)

References

Details

Attachments

(2 files)

Attached image image.png

Thunderbird 89.0b1
macOS 10.15.7 in Dark Mode
System Theme

The fields and button labels in the mail header pane are dark text on dark background.

Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Attachment #9218052 - Flags: review?(richard.marti)

Comment on attachment 9218052 [details] [diff] [review]
1707273-message-header.diff

Many thanks for fixing this.

Attachment #9218052 - Flags: review?(richard.marti) → review+
Target Milestone: --- → 90 Branch

Comment on attachment 9218052 [details] [diff] [review]
1707273-message-header.diff

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: wrong text color in message header with dark theme
Testing completed (on c-c, etc.): soon on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9218052 - Flags: approval-comm-beta?

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/b49c9f29fc52
[macOS] Fix wrong text color in the message header for dark themes. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1707355
Duplicate of this bug: 1707619

Comment on attachment 9218052 [details] [diff] [review]
1707273-message-header.diff

[Triage Comment]
Approved for beta

Attachment #9218052 - Flags: approval-comm-beta? → approval-comm-beta+

Confirm the issue is resolved in 89.0b2

(In reply to Jason from comment #10)

Confirm the issue is resolved in 89.0b2

thanks!

Status: RESOLVED → VERIFIED

Thanks! Working on Win10 89.0b3.

You need to log in before you can comment on or make changes to this bug.