Closed Bug 1707983 Opened 1 year ago Closed 7 months ago

Pinch-zooming doesn't work in tabs that have been dragged into a different window

Categories

(Core :: Panning and Zooming, defect, P2)

All
Unspecified
defect

Tracking

()

VERIFIED FIXED
97 Branch
Tracking Status
firefox97 --- verified

People

(Reporter: mstange, Assigned: tnikkel)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Steps to reproduce:

  1. Pinch-zoom a page and verify that it works.
  2. Drag the tab into a different window (could be an existing window, or a new window by detaching the tab).
  3. Pinch-zoom the page again, in the different window.

Expected results:
Pinch-zooming should work normally.

Actual results:
Nothing happens in response to the pinch-zoom gesture.

If the tab is dragged back into the original window, pinch-zooming works again.

The zoom constraints do not allow zoom, which means they probably haven't gotten an update from content at all and are in their initial values. Not a recent regression, 2020-11-01 has this bug.

Blocks: desktop-zoom

Fix is probably just hooking up the zoom constraints client to a notification to refresh zoom constraints when we do a swapDocShells call, but what notification that is, not sure.

I guess we need to do this every time we get a new APZC tree manager (because that is where the zoom constraints map/cache is stored). I'm not sure how to detect that or if there are other cases we haven't covered.

Assignee: nobody → tnikkel
Status: NEW → ASSIGNED

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:tnikkel, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(tnikkel)
Flags: needinfo?(botond)
Flags: needinfo?(botond)

A test needs to be written.

Flags: needinfo?(tnikkel)
Severity: -- → S3
Priority: -- → P2
Duplicate of this bug: 1737887
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e7b011f92cf4
Refresh zoom constraints from UIResolutionChanged notification because it gets called when we swap docshells and get a new APZC tree manager. r=botond
https://hg.mozilla.org/integration/autoland/rev/fd1d5e8fb5d0
Add test. r=hiro
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 97 Branch
Flags: qe-verify+

Reproduced this bug using an affected Nightly build (2021-04-27), using Win 10 x64 with touchscreen.

The issue is verified as fixed on latest Beta 97.0b7.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.