Closed Bug 1708263 Opened 3 months ago Closed 2 months ago

[Proton Address Bar] Focus Ring flickers/appears when focussing the Addressbar by clicking on the Address Bar border

Categories

(Firefox :: Address Bar, defect, P3)

defect
Points:
3

Tracking

()

VERIFIED FIXED
91 Branch
Tracking Status
firefox90 --- wontfix
firefox91 --- verified

People

(Reporter: mehmet.sahin, Assigned: daisuke)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-address-bar])

Attachments

(2 files)

Attached video screencast.mov

Nightly 90.0a1 (2021-04-27) (64-Bit)
macOS 11.2.3

1.) Focus the Address Bar with the Mouse Cursor when the cursor is only over the Address Bar border.

Actual: A small flicker appears

Expected: No flicker.

This is another variant of the recently fixed Bug 1700374.

This issue is probably very low prio and it is really an edge case, because you normally focus the Address Bar when the mouse cursor is fully in the Address Bar.

A screencast is attached.

Thanks :)

Severity: -- → S4
Priority: -- → P2
Whiteboard: [proton-address-bar]

I don't think this is a P2, we should let Romain eval it

Priority: P2 → --

Agreed, feels low occurence/low impact, can be a P3

Priority: -- → P3
Assignee: nobody → daisuke
Status: NEW → ASSIGNED
Points: --- → 3
Blocks: 1715699
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b3d6d89affd8
Avoid flickering focus ring when focusing urlbar by clicking on edge of urlbar. r=harry
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

The patch landed in nightly and beta is affected.
:daisuke, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(daisuke)
Flags: needinfo?(daisuke)

I reproduced this issue using Fx 90.0b11 on macOS 10.13.
I can confirm this issue is fixed, I verified using Fx 91.0a1 on Windows 10 x64, macOS 10.13 and Ubuntu 20.04.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.