Closed Bug 1717611 Opened 11 months ago Closed 8 months ago

Missing sources when navigating through the history

Categories

(DevTools :: Debugger, defect, P2)

defect

Tracking

(Fission Milestone:Future)

RESOLVED DUPLICATE of bug 1726568
Fission Milestone Future

People

(Reporter: Honza, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: dt-fission-future, dt-perf-stability-mvp)

Prefs:

  • fission.autostart => true
  • devtools.target-switching.server.enabled => true
  • fission.bfcacheInParent => true

STRs:

  1. Open a new blank tab
  2. Open DevTools and select the Debugger panel
  3. Navigate the page to http://softwareishard.com/tests/fission/case1/index.html
  4. Navigate the page to https://www.google.com/
  5. Press the back button (load again the page from #3) - Sometimes the Debugger doesn't show any sources atm =>BUG
  6. Press the back button (load again the blank tab) => The Debugger should show some sources.
  7. Press the Forward button (load again the page from #3) => The Debugger doesn't show any sources =>BUG

Honza

Depends on: 1713607

I just retested with patches from bug 1713607, I can still see the issue. The sources are missing.

This issue yet need to be triaged. If it isn't fixed by the work done in bug bug 1713607 - I believe that it doesn't have to be in M3. Debugging while navigation in BFCache is not a standard way how to debug pages and can be fixed in Post M8

Honza

Btw. I am seeing missing source even if Fission is disabled.

The sources are also missing for workers, see https://bugzilla.mozilla.org/show_bug.cgi?id=1691588#c7

Fission Milestone: --- → Future
Whiteboard: dt-fission-m3-triage → dt-fission-future

Jan,

Can we test this with/without Fission to get a better idea of the priority?
Thanks

Flags: needinfo?(odvarko)

The behavior (of history navigation) changed a bit, so here are updated steps
(it isn't possible to go back to the about:blank page opened first)

Prefs:

  • fission.autostart => true
  • devtools.target-switching.server.enabled => true
  • fission.bfcacheInParent => true

STRs:

  1. Open a new blank tab
  2. Open DevTools and select the Debugger panel
  3. Navigate the page to http://softwareishard.com/tests/fission/case1/index.html
  4. Navigate the page to https://www.google.com/
  5. Press the back button (load again the page from #3) - the Debugger doesn't show any sources =>BUG

I can see the sources when fission.bfcacheInParent => false
So, this looks like an issue with BFCache in parent

Not Fission blocker, so Future milestone seems to be correct.

Honza

Flags: needinfo?(odvarko)
Whiteboard: dt-fission-future → dt-fission-future, dt-perf-stability-triage

This bug affects the Storage panel as well:

STRs

  1. Load http://janodvarko.cz/tests/fission/case2/index.html
  2. You should see two URLs under Local Storage
  3. Load google.com, go back
  4. There is just one URL under the Local Storage (odvarko.com iframe URL is missing)

Looks like we are missing remote iframe targets when navigating back in the history.

Honza

Severity: -- → S3
Priority: -- → P2
Whiteboard: dt-fission-future, dt-perf-stability-triage → dt-fission-future, dt-perf-stability-mvp

Closing as this was issue was fixed when Bug 1726568 Landed.

Also the Local Storage STR in Comment 6 has been fixed.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1726568
You need to log in before you can comment on or make changes to this bug.