Closed Bug 1720261 Opened 1 year ago Closed 1 year ago

Fix import/export profile on Windows

Categories

(Thunderbird :: Account Manager, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr78 unaffected, thunderbird_esr91 wontfix, thunderbird91+ wontfix)

RESOLVED FIXED
92 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird_esr91 --- wontfix
thunderbird91 + wontfix

People

(Reporter: rnons, Assigned: rnons)

References

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → remotenonsense
  • Fix path separator on Windows
  • Do not copy IMAP mail folders on Windows to prevent a broken account
  • Change to only support importing from zip file, since nsIFilePicker doesn't support folder mode and zip file mode at the same time
Status: NEW → ASSIGNED
Target Milestone: --- → 92 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1790fb20e924
Fix import/export profile on Windows. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Uplift to beta?

Flags: needinfo?(remotenonsense)
Version: unspecified → Thunderbird 91

Comment on attachment 9230911 [details]
Bug 1720261 - Fix import/export profile on Windows. r=darktrojan

[Approval Request Comment]
Regression caused by (bug #): bug 271863
User impact if declined: import/export doesn't work on Windows
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): Low, doesn't work anyway.

Flags: needinfo?(remotenonsense)
Attachment #9230911 - Flags: approval-comm-beta?

Comment on attachment 9230911 [details]
Bug 1720261 - Fix import/export profile on Windows. r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9230911 - Flags: approval-comm-beta? → approval-comm-beta+
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Attachment #9230911 - Flags: approval-comm-beta+

What is the plan for the profile export feature in context to 91 Release and following point releases after backing this out?

We'll consider uplifting all the needed patches later when it's had enough time to bake.
But there are complications esp due to localization, so might not happen.

You need to log in before you can comment on or make changes to this bug.