Closed Bug 271863 Opened 20 years ago Closed 3 years ago

Import/Export account info

Categories

(Thunderbird :: Account Manager, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

(thunderbird_esr78 wontfix, thunderbird_esr91 wontfix, thunderbird91 wontfix)

RESOLVED FIXED
91 Branch
Tracking Status
thunderbird_esr78 --- wontfix
thunderbird_esr91 --- wontfix
thunderbird91 --- wontfix

People

(Reporter: bugzilla, Assigned: rnons)

References

(Blocks 1 open bug)

Details

Attachments

(7 files)

I just reinstalled my PC at home and could really need and extension for
Thunderbird.

I just the same Thunderbird setup at work and at home. So same accounts, name
sigs, etc.

I would like to be able to export one or multiple accounts to an XML file and
then import it again. So export all my accounts at work and import then at home.

This could also be used for pushing account setup files from ISP's
This could also be used to blow away your windows installation and install a
real OS, but not lose any mail or settings or addresses.
Yes, I just migrated from MSFT to Fedora and like to import my settings.

Also I have to keep my office and home box in sync. Exporting/Importing Message filters is especially important to me.

-cheers
This would be indeed a very useful feature. There are a handful howtos on the net (f.e. [1]), but they usually involve copying, deleting & editing a number of files. It should be much easier to copy a profile from one thunderbird installation to another, even cross-plattform. 

There seem to be a lot of bugs or RFE related to this topic in one way or another, i would namely add:

bug 314744 ("No Option to export mail/settings") 

and probably 

bug 254668 ("Remove hardcoded paths from prefs.js")

A solution to this would certainly be very appreciated...


[1] http://www.thunderbird-mail.de/hilfe/faq1.5/index.php/#import_restore
Adding bug 335495 and bug 275785 to my list above.
QA Contact: account-manager
I'd like this functionality too, specifically import/export of account info. Setting up a dozen identities every time I reinstall or move to another computer is very frustrating. I realise I could simply copy my profile, but there's a risk that won't work across versions, and sometimes you just want to start afresh with the basics.

I've no interest in import/export of mail, but I realise that could be useful for some. Import/export of Addons could be another useful feature.
I'd like to see this feature extended to allow a company to send out a signed file that people could click on to install the corporate mail server and newsgroup info.

I wonder if this feature would also be good for automated QA of Thunderbird.
I wonder if some of the work we've started poking around with to do Weave interop could help with the use case in comment #0 (even if people don't want to use the weave service for the feature, we'll have to do the serialization/deserialization of the data).

Bob, your use case could probably be done as a side effect of the work we're doing in bug 422814 -- exporting & importing AccountConfigs should be pretty easy to do, once that work lands. 
Assignee: mscott → nobody
what's about sync like in Firefox?

I have a similar request for exporting/importing mailbox settings: Rationale is: You set up your mailbox/account on one machine and want to save it (preferably to some small text file). If you use some live system based on a RAM disk, you want to read mail by importing your mailbox/account settings. Or you go to some (trusted) Internet Cafe, or you use a disposable VM in Qubes OS, or...

If we do this we probably want to allow importing all of the profile or all of the account (not just the settings).

List Thunderbird as an option in Tools-> Import -> Import Everything.

Depends on D118319.

Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED

Tools-> Import -> Import Everything.

Depends on D118681.

Tools-> Import -> Import Everything.

Depends on D118788.

Setting leave-open because I will work on a patch to support importing from a zip file.

Target Milestone: --- → 91 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/3d35e84a004b
Support importing mail accounts and mail folders from a TB profile directory. r=darktrojan
https://hg.mozilla.org/comm-central/rev/8cda351f097b
Support importing addressbook from a TB profile directory. r=darktrojan
https://hg.mozilla.org/comm-central/rev/e9eac2dfac39
Support importing passwords and prefs from a TB profile directory. r=darktrojan

  • Extract selected zip file to a tmp dir, then use it as the source profile dir
  • Use .directory-rel to import mail folders, because .directory may not exists
  • Transform the value of ldap_2.autoComplete.directoryServer
  • Add an Export menu item to the main menu and app menu
  • Add an exportDialog.xhtml

Depends on D119024.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/ab10e1fe3f3e
Support importing from a zipped TB profile. r=darktrojan

For storage calendars, we need to import everything from the source local.sqlite to the target local.sqlite, maybe support it another time.

Depends on D119168.

Blocks: 1719582

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/efd3cd4bc275
Support exporting the current profile to a zip file. r=darktrojan
https://hg.mozilla.org/comm-central/rev/a3b5e92bc304
Support importing calendars. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED

Didn't have time to test but exciting to see this land.

Maybe we should link to profile importing during account setup as well. As well as account central.

(In reply to Magnus Melin [:mkmelin] from comment #23)

Didn't have time to test but exciting to see this land.
Maybe we should link to profile importing during account setup as well. As well as account central.

Oh wow!
Yes, this is great and we should definitely hook it up tot he new account setup tab.
Great stuff.

woo-hoo

We also need this mentioned in the app upgrade dialog. That would help our support folks and reduce the "need to downgrade my profile" requests.

See Also: → 1167920

Very nice Enterprise level Feature.

When I tested export in windows, it is never finished. It was at 70%. I clicked close button. Dialog was gone without any warning.

If there is no option to select mail, filter, contact, etc like in import dialog.

Regressions: 1720261
Depends on: 1720261
No longer regressions: 1720261
Attached image options for export.png
Blocks: 1722938
Depends on: 1723471
Depends on: 1723472
Depends on: 1723482
Depends on: 1723486
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED

Is there any documentation on how to use this?

There used to be a separate program, called "Mozbackup", which did this. It was pretty intuitive to use.

Thanks.

In a beta or daily build, use Tools > Import/Export menu.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: