Java popup menus are displayed at the wrong offset

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: EPS1, Assigned: sfraser_bugs)

Tracking

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
When I connect to http://www.silverbulletcomicbooks.com/index.htm?contents=main.htm
the site's menu bar doesn't display correctly.

Comment 1

17 years ago
EPS1@mac.com, what build ID are you reporting this bug against?

Comment 2

17 years ago
Also, please be more specific about how this page is incorrectly displayed.

Comment 3

17 years ago
The menu in question appears to be a Java applet. The pop-up listings do not
position themselves correctly relative to the rest of the menu. I'm seeing this
in the 2002102204 build. Changing component to Plug-ins and updating summary.
Component: Accessibility → Plug-ins
Summary: Display bug → Display bug in java pop-up menu
(Assignee)

Comment 4

16 years ago
Confirming.
Assignee: bryner → sfraser
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Display bug in java pop-up menu → Java popup menus are displayed at the wrong offset
QA Contact: sairuh → petersen

Updated

16 years ago
Blocks: 113492

Comment 5

16 years ago
I'm seeing this error aswell..
latest java 1.4.2 and latest stable 1.4 mozilla
an example site is www.arach.net.au
trying to browse the menus at the top results in secondary trees being offset
incorrectly.
offsets are relative values
but mozilla is positioning them absolutely.
Could someone add a screenshot. Its seems to me that this bug is gone. Reporter,
Kaldari could you check with a recent nightly build ?

Comment 7

16 years ago
The menu is appearing a significant distance below the menu bar. I think the
bug is still alive and well.

Also, (quite possibly unrelated) I managed to get a crash after messing about
with the menus a lot. Unfortunately, I didn't have Crash Reporter turned on and
have since been unable to replicate the crash. The menu bar also managed to
move around when resizing the window, and ended up being drawn on top of the
scroll bar and tool bar; but I believe there is already a bug covering this
sort of thing.

Comment 8

16 years ago
Posted image Menus at site mentioned in comment 5 (obsolete) —
This one's even more obviously wrong - the submenu is appearing above and a
long way to the left of the menu, when it should appear just to the right.

Comment 9

16 years ago
Sorry, forgot to mention that those screenshots were taken with the 2003090302 NB.

Comment 10

16 years ago
Site mentioned in comment 5 is not this bug.. at all

- Its a menu done with javascript and not java
- reporter claims it was seen in mozilla as well, the original bug here is not
- it WFM in 1.5b os x as well as Camino 2003090202

If it still is happening for someone else a new bug should be opened against
Browser (probably general unless someone wants to debug the js code and figure
out if its evang or a real bug somewhere)

Comment 11

16 years ago
Comment on attachment 130823 [details]
Menus at site mentioned in comment 5

not this bug
Attachment #130823 - Attachment is obsolete: true
The problem described by the reporter goes away when one installs the Java
Embedding Plugin (bug 197813 / http://javaplugin.sourceforge.net/).  

Without the JEP, I see the same behavior as attachment 130821 [details].

20041015 (0.8+) nightly, OS X 10.3.5, Apple Java 1.4.2 Update 2

I imagine this new info might suggest changing some bug fields, but even if I
had that power, I wouldn't know where to begin :)  Adding myself to cc.

Updated

14 years ago
Blocks: 224615
Fixed by bundling the Java Embedding Plugin with Camino (nightly builds 20050729
and later), bug 301076.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.