[FEATURE] News disk space management

VERIFIED FIXED in Future

Status

MailNews Core
Backend
P4
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: laurel, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
This is a bug to track implementation of the disk space management features for
news.

Prefs UI location for global settings:  Edit|Prefs|Mail&News|Disk
Space|"Newsgroup Messages Only"

Prefs.js:  news.keep.<various prefs>

Please let us know if there will be per newsgroup override of the global
settings as 4.x did with the newsgroup Properties dialog.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → huang

Updated

19 years ago
Target Milestone: M20

Comment 2

19 years ago
Moving to M20, which is close to the edge for seamonkey

Comment 3

18 years ago
P4 per m/n staff mtg today
Priority: P3 → P4
not going to happen for 6.0, since this is offline related.

Comment 5

18 years ago
Moving target milestone to "future" to be reviewed at a later time
Target Milestone: M20 → Future
(Reporter)

Comment 6

18 years ago
mass change of huang's news bugs to stephend.
QA Contact: huang → stephend
(Reporter)

Comment 7

18 years ago
*** Bug 61498 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

18 years ago
I think I'm going to have a crack at this as part of offline support
Assignee: sspitzer → bienvenu
Status: ASSIGNED → NEW

Comment 9

18 years ago
david - you posted the prefs for this in the mail newsgroup.  If you are going
to check that in, can you post the prefs here for the record?
(Reporter)

Comment 10

18 years ago
*** Bug 67191 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
wow, very old bug
(Assignee)

Comment 12

18 years ago
Here's the newsgroup posting I made:

I've landed some support for this. There's no UI for it yet, so the only thing
you can do is set per-newsgroup server defaults, which apply to all the
newsgroups on that server. Here are some example prefs:


user_pref("mail.server.server1.daysToKeepBodies", 10); // for offline msg body
use, not used yet.
user_pref("mail.server.server1.daysToKeepHdrs", 0);    // ignored unless
retainBy == 2
user_pref("mail.server.server1.keepUnreadOnly", false);
user_pref("mail.server.server1.numHdrsToKeep", 500); // ignored unless retainBy == 3
user_pref("mail.server.server1.retainBy", 3);

The retainBy settings are as follows:
 nsMsgRetainAll = 0;
 nsMsgRetainByServerDefaults = 1; // not meaningful for server settings, only
meaningful for a newsgroup.
 nsMsgRetainByAge = 2;
 nsMsgRetainByNumHeaders = 3;

So, the example prefs say to keep only 500 hundred headers.

The keepUnreadOnly pref is orthogonal to the other hdr retention settings. For
example, if set to true, and numHdrsToKeep is 500, we'll only keep unread
headers, and we'll only keep up to 500 of them.

The retention settings are applied when you open a newsgroup, before new headers
are downloaded.

I haven't tested this a lot, so there are likely to be some problems, but feel
free to try it out.  If you find any problems, you can add them to the comments
for this bug.
Status: NEW → ASSIGNED

Comment 13

18 years ago
Shouldn't this be fixed by M0.9 so our hard drives don't explode while we're all
testing mozilla on a daily basis.

I've got tens of thousands of news headers just aching for this feature ;)
Peter, the User Interface isn't in yet, but the prefs should work.  David, do
they go in all.js or prefs.js?
(Assignee)

Comment 15

18 years ago
Peter, you can try it now by editing your prefs.js by hand (after backing it up,
and shutting down mozilla)

I'm not doing the UI, so I'm not sure when it will be done.

Comment 16

18 years ago
Thanks. The UI should be simple enough to implement (I hope), and therefore
should come in soon (again, I hope). I think I'll wait for the UI, since the
idea of making all those settings (i have many newsservers) by hand is not very
appealing.

BTW, in "retainBy" do you put the number (1, 2, 3,...) or the text (e.g.
"nsMsgRetainByNumHeaders")?

Any ETA for the UI?
(Assignee)

Comment 17

18 years ago
you put the number, as in the example above.
(Assignee)

Comment 18

17 years ago
the backend for this is done. I don't know about the front end...if the front
end isn't done, open up new bugs on the front end.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Front end is in there also.  In Mail/News, Edit | Mail/News Account Settings |
Offline & Disk Space.

Builds:

Windows 2000 build 2001052708
Mac OS 9.1 build 2001052508
Linux build 2001052706
Status: RESOLVED → VERIFIED

Comment 20

17 years ago
This isn't fixed yet. Make *status = new* because the frontend doesn't work
correctly yet.

For my newsgroups, I selected "Compact folders when it will save over 100 kb",
but when i OK out and go back in to prefs, the checkbox is gone :(
Well, David didn't do the front end, this bug was really a tracker bug to make
sure the feature was implemented (he coded the back end).  I believe the front
end was done by Diane Sun, regardless, please file new bugs.  

Comment 22

17 years ago
I created bug 82984 to deal with the non-functioning "Compact folders when it
will save over 100 kb".

Comment 23

17 years ago
Stephen, could you add diane sun to the CC of bug 82984? I don't know her email
address.

Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.