Closed Bug 1722258 Opened 3 months ago Closed 3 months ago

Create a WindowRenderer implementation that uses layerless painting

Categories

(Core :: Web Painting, task)

task

Tracking

()

RESOLVED FIXED
92 Branch
Tracking Status
firefox92 --- fixed

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

We still have a few uses of BasicLayerManager/FrameLayerBuilder (even when WR is enabled) for widgets that want a super lightweight in-thread rendering.

We can rasterize a display list directly now, so we should add a new WindowRenderer (formerly LayerManager) implementation for widgets to hold that just runs this without any retaining/invalidation.

Assignee: nobody → matt.woodrow
Status: NEW → ASSIGNED
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4149d596d03d
Split out fallible composite-only path of PresShell::Paint. r=miko
https://hg.mozilla.org/integration/autoland/rev/41176d476eb7
Convert more LayerManager usage to use WindowRenderer. r=miko
https://hg.mozilla.org/integration/autoland/rev/cf8a1175abd1
Add FallbackRenderer to replace BasicLayerManager usage. r=miko
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
Regressions: 1722958
Status: RESOLVED → REOPENED
Flags: needinfo?(matt.woodrow)
Resolution: FIXED → ---
Target Milestone: 92 Branch → ---
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce8f605d6920
Split out fallible composite-only path of PresShell::Paint. r=miko
https://hg.mozilla.org/integration/autoland/rev/e8299f044303
Convert more LayerManager usage to use WindowRenderer. r=miko
https://hg.mozilla.org/integration/autoland/rev/e505fffd43c3
Add FallbackRenderer to replace BasicLayerManager usage. r=miko
Flags: needinfo?(matt.woodrow)
Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
Regressions: 1724848
Regressions: 1725185
Regressions: 1725175

Hi Matt, given the number of regressions already reported from this change and the incoming reports we're still getting, what do you think about backing this out from Beta92 so it has more Nightly bake time first? I've confirmed that it reverts cleanly.

Flags: needinfo?(matt.woodrow)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #9)

Hi Matt, given the number of regressions already reported from this change and the incoming reports we're still getting, what do you think about backing this out from Beta92 so it has more Nightly bake time first? I've confirmed that it reverts cleanly.

It's a tough call! We're hoping to remove a lot of the Layers code from Nightly93, so any regressions after that won't have a fallback option.

I think I'd prefer to try uplift the fix (up for review now, need to confirm that it's the same for all the regressions) if possible, since it's early in the beta cycle.

Flags: needinfo?(matt.woodrow)
Regressions: 1725361
Regressions: 1726802
Duplicate of this bug: 1721268
Regressions: 1724617
Duplicate of this bug: 1562295
You need to log in before you can comment on or make changes to this bug.