Closed Bug 1722514 Opened 1 year ago Closed 1 year ago

Can not drag and drop one tab outside the current window to create a new window on wayland

Categories

(Core :: Widget: Gtk, defect, P3)

Firefox 90
defect

Tracking

()

RESOLVED DUPLICATE of bug 1729423

People

(Reporter: david3bizzarri, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:90.0) Gecko/20100101 Firefox/90.0

Steps to reproduce:

  1. Open multiple tabs and windows
  2. Try to drag and drop a tab outside the current window to move it in a new window

Actual results:

Nothing

Expected results:

A new window should be created with the dragged tab

From the attached video is possible to see that it works only in one specific situation. Also, I'm using Firefox on Fedora 34 with Wayland, the issue doesn't happen if I switch to the X server.

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Blocks: wayland
Flags: needinfo?(david3bizzarri)
Priority: -- → P3

I'm running Firefox 91.0.1 on Wayland, and I cannot reproduce this. I can drag a tab out of the window to make a new window, and I can drag a tab into the tab bar of an existing window to move it to that window.

Should be fixed now in latest nightly.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1729423
You need to log in before you can comment on or make changes to this bug.