Closed Bug 1725149 Opened 3 months ago Closed 2 months ago

[Wayland] Implement async clipboard

Categories

(Core :: Widget: Gtk, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We may provide alternative clipboard (async) for Wayland code to text/fix various clipboard issues we have on Wayland now.

When widget.wayland.async-clipboard.enabled use async clipboard and D&D handlers provided by Gtk.

I use this command for local testing:

MOZ_ENABLE_WAYLAND=1 ./mach mochitest dom/base/test/test_copypaste.html --setpref widget.wayland.test-workarounds.enabled=true --setpref widget.wayland.async-clipboard.enabled=true --enable-webrender

Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/ca7dd68c51a2
[Wayland] Implement async clipboard, r=rmader
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

To enable the async clipboard support, please go to about:config, set widget.wayland.async-clipboard.enabled to true and restart browser.

It works perfectly now, both with and without the option enabled.
Thank you all !

On my system (GNOME Wayland / Arch Linux) there's a visible delay (~500 ms?) between pasting and the new text being displayed, which is quite annoying when you're pasting into the address bar.

(In reply to mcnuggetsrooster from comment #6)

It works perfectly now, both with and without the option enabled.
Thank you all !

Sorry, bad thread...
#1722197

Blocks: 1727268

(In reply to Laurențiu Nicola from comment #7)

On my system (GNOME Wayland / Arch Linux) there's a visible delay (~500 ms?) between pasting and the new text being displayed, which is quite annoying when you're pasting into the address bar.

Can you open a new bug for it and attach clipboard log of that? (run with MOZ_LOG="WidgetClipboard:5" env variable).
Thanks.

Flags: needinfo?(grayshade)

I will, but I'd rather wait for bug 1727268, just in case it's caused by blocking on that mutex.

I have another question: I'm seeing relatively many clipboard-related crashes, some with different stack traces. crash-stats.mozilla.org doesn't have a bug associated with them. Should I do anything about this, maybe click "File a bug" on c-s.m.o?

Flags: needinfo?(grayshade)
Blocks: 1727285

Can you open a new bug for it and attach clipboard log of that?

Already did, bug 1726360.

Depends on: 1726360
Blocks: 1726360
No longer depends on: 1726360

(In reply to Laurențiu Nicola from comment #10)

I will, but I'd rather wait for bug 1727268, just in case it's caused by blocking on that mutex.

I have another question: I'm seeing relatively many clipboard-related crashes, some with different stack traces. crash-stats.mozilla.org doesn't have a bug associated with them. Should I do anything about this, maybe click "File a bug" on c-s.m.o?

Feel free to file them, I can look at it.

I've just downloaded and installed FF93 from the Fedora 34 repository. Alas, this problem is not fixed. Can we take a look at this again?

Flags: needinfo?(stransky)

Async clipboard was implemented in 93 but it's enabled by default at 94. In 93 you need to go to about:config and set widget.wayland.async-clipboard.enabled to true and restart browser.

Flags: needinfo?(stransky)

Confirmed. Works like a charm. Thanks for all the hard work. I appreciate it very much.

Setting widget.wayland.async-clipboard.enabled to true also seems to have fixed a problem I had (on Fedora 34) where I could copy from other applications and paste to Firefox, but not copy in FIrefox and paste to other applications. Thank you.

https://lists.fedoraproject.org/archives/list/users@lists.fedoraproject.org/thread/A5QIZUWHVUSEL6ZUHXOQDYN2TNFTDXCM/

You need to log in before you can comment on or make changes to this bug.