Closed Bug 1726606 Opened 2 months ago Closed 2 months ago

Default FFHCM to "never" on MacOS

Categories

(Core :: Disability Access APIs, defect, P1)

Desktop
macOS
defect

Tracking

()

VERIFIED FIXED
93 Branch
Tracking Status
firefox-esr91 92+ verified
firefox91 + verified
firefox92 + verified
firefox93 + verified

People

(Reporter: morgan, Assigned: morgan)

References

Details

(Whiteboard: [hcm-2021-h2])

Attachments

(1 file)

As above.

Recently, we decided to default FFHCM to "with HCM themes" on MacOS, but this has caused some confusion for users for whom "increase contrast" previously had no effect on FF HCM. We should revert (and uplift) this change, restoring the UX we had before.

Attachment #9237089 - Attachment description: WIP: Bug 1726606: Default browser.display.document_color_use to 1 on MacOS r?emilio → Bug 1726606: Default browser.display.document_color_use to 1 on MacOS r?emilio
Summary: Decouple FF HCM from Increase Contrast on MacOS → Default FFHCM to "never" on MacOS
Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b1db4e355714
Default browser.display.document_color_use to 1 on MacOS r=emilio
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Comment on attachment 9237089 [details]
Bug 1726606: Default browser.display.document_color_use to 1 on MacOS r?emilio

Beta/Release Uplift Approval Request

  • User impact if declined: MacOS users running with "Increase Contrast" set at the OS level will continue to have FF HCM enabled by default.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Launch a clean profile in MacOS
    In about:preferences > Language and Appearance > Colors, verify the dropdown value is initially "Never".
    Navigate to data:text/html,<div style="background:green; border:10px solid blue;">hello world</div> and verify colors are visible (ie. not flattened to black and white)
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch changes the default (but not necessarily current) value of a preference. Users still have the ability to change this value in about:preferences UI.
  • String changes made/needed:
Attachment #9237089 - Flags: approval-mozilla-beta?
Flags: qe-verify+
See Also: → 1726680

Comment on attachment 9237089 [details]
Bug 1726606: Default browser.display.document_color_use to 1 on MacOS r?emilio

See form filled above :)

Attachment #9237089 - Flags: approval-mozilla-release?

Comment on attachment 9237089 [details]
Bug 1726606: Default browser.display.document_color_use to 1 on MacOS r?emilio

Approved for 92.0b7.

Attachment #9237089 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified fixed with Firefox 92.0b7 (20210822190301) and 93.0a1 (20210822212235) on macOS 10.15 and 11.5 ARM. The value from the drop down inside about:preferences > Language and Appearance > Colors is set to never and the blue/green colors from the attached test case are displayed as expected when using Increase Contrast.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment on attachment 9237089 [details]
Bug 1726606: Default browser.display.document_color_use to 1 on MacOS r?emilio

approved for 91.0.2

Attachment #9237089 - Flags: approval-mozilla-release? → approval-mozilla-release+
Duplicate of this bug: 1725899
Duplicate of this bug: 1725341

Verified fixed using Firefox 91.0.2 (20210823123856) on macOS 10.15 and macOS 11.5 ARM. The value from the drop-down inside about:preferences > Language and Appearance > Colors is set to Never and the blue/green colors from the attached test case from comment 4 are displayed as expected when using Increase Contrast.

Hi Morgan, I believe we'll need this on ESR91 also? Can you please nominate if that's correct? No need to fill out the questionnaire again.

Flags: needinfo?(mreschenberg)

Comment on attachment 9237089 [details]
Bug 1726606: Default browser.display.document_color_use to 1 on MacOS r?emilio

ESR Uplift Approval Request

see above

:)

Flags: needinfo?(mreschenberg)
Attachment #9237089 - Flags: approval-mozilla-esr91?

Comment on attachment 9237089 [details]
Bug 1726606: Default browser.display.document_color_use to 1 on MacOS r?emilio

Approved for 91.1esr.

Attachment #9237089 - Flags: approval-mozilla-esr91? → approval-mozilla-esr91+
Duplicate of this bug: 1725978

Verified fixed with 91.1.0esr (20210901125518) on macOS 11.5 ARM and 10.15.

Duplicate of this bug: 1726187
Whiteboard: [hcm-2021-h2]
You need to log in before you can comment on or make changes to this bug.