Closed Bug 1726763 Opened 1 year ago Closed 1 year ago

CC:/BCC: dialog does not start/work after saving mail draft TB91 WIN10prof

Categories

(Thunderbird :: Message Compose Window, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1726280

People

(Reporter: focus, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

open compose (new message).
type TO:
type a part of the message
type Ctrl+S (draft is created)
try to type CC: / BCC:

Actual results:

Button is highlighted but nothings happens

Expected results:

CC: / BCC: dialog should open

First solution:
close draft
re-open saved draft
type CC: / BCC:
CC: / BCC: dialog starts

SAVE the draft blocks the editing of TO:/CC:/BCC: and Subject:

WIN10pro 21H1 19043.1165
TB 91.0.1 (64-Bit)

try to type CC: / BCC:

Is there new information in tools > developer > error console after clicking CC?

Does the problem reproduce after doing Help > Troubleshooting mode > restart ?

Blocks: tb91found
Component: Untriaged → Message Compose Window
Flags: needinfo?(focus)

Cc/Bcc never opens any dialog - it's just about revealing those fields.
But, you need to click it - typing "CC:" doesn't do anything.
Maybe you're using some (defunct) add-on? Tried Help | Troubleshoot mode ?

Error Console after click "Ctrl-S"

in getEncryptionFlags, gSendEncrypted=false, gSendSigned=true enigmailMsgComposeOverlay.js:1619:13
Prompter: internal dialogs not available in this context. Falling back to window prompt. Prompter.jsm:1084
getCryptParams parameters: from=0x58FF4C995709BDB0, to=, bcc=, hash=SHA256, flags=4802, ascii=0, errorObj=
Object { value: "" }
, logObj=
Object { }
encryption.jsm:73:13
getCryptParams, got: to=, bcc= encryption.jsm:113:13
getCryptParams returning: encryption.jsm:190:13
Object { sender: "0x58FF4C995709BDB0", sign: false, signatureHash: "", sigTypeClear: false, sigTypeDetached: false, encrypt: true, encryptToSender: true, armor: true, senderKeyIsExternal: false, to: [], … }
encryption.jsm:191:13
sendFlags=000012c2 encryption.jsm:426:13
Uncaught
Exception { name: "NS_ERROR_FAILURE", message: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIEditor.getInlineSpellChecker]", result: 2147500037, filename: "chrome://messenger/content/messengercompose/MsgComposeCommands.js", lineNumber: 401, columnNumber: 0, data: null, stack: "updateEditableFields@chrome://messenger/content/messengercompose/MsgComposeCommands.js:401:38\nToggleWindowLock@chrome://messenger/content/messengercompose/MsgComposeCommands.js:2654:23\nComposeProcessDone@chrome://messenger/content/messengercompose/MsgComposeCommands.js:680:21\n_doFcc2/<@resource:///modules/MessageSend.jsm:962:12\nnotify@resource://gre/modules/Timer.jsm:62:17\n", location: XPCWrappedNative_NoHelper }
MsgComposeCommands.js:401

Flags: needinfo?(focus)

No Add-On, No Theme-Change

Error Console after click "Ctrl-S" using an other/different eMail account

Prompter: internal dialogs not available in this context. Falling back to window prompt. Prompter.jsm:1084
set modalType resource://gre/modules/Prompter.jsm:1084
ModalPrompter resource://gre/modules/Prompter.jsm:1040
getPrompt resource://gre/modules/Prompter.jsm:65
CompleteGenericSendMessage chrome://messenger/content/messengercompose/MsgComposeCommands.js:4874
GenericSendMessage chrome://messenger/content/messengercompose/MsgComposeCommands.js:4810
SaveAsDraft chrome://messenger/content/messengercompose/MsgComposeCommands.js:5424
Save chrome://messenger/content/messengercompose/MsgComposeCommands.js:5402
doCommand chrome://messenger/content/messengercompose/MsgComposeCommands.js:909
doCommand chrome://messenger/content/messengercompose/MsgComposeCommands.js:1126
goDoCommand chrome://global/content/globalOverlay.js:123
oncommand chrome://messenger/content/messengercompose/messengercompose.xhtml:1
Uncaught
Exception { name: "NS_ERROR_FAILURE", message: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIEditor.getInlineSpellChecker]", result: 2147500037, filename: "chrome://messenger/content/messengercompose/MsgComposeCommands.js", lineNumber: 401, columnNumber: 0, data: null, stack: "updateEditableFields@chrome://messenger/content/messengercompose/MsgComposeCommands.js:401:38\nToggleWindowLock@chrome://messenger/content/messengercompose/MsgComposeCommands.js:2654:23\nComposeProcessDone@chrome://messenger/content/messengercompose/MsgComposeCommands.js:680:21\n_doFcc2/<@resource:///modules/MessageSend.jsm:962:12\nnotify@resource://gre/modules/Timer.jsm:62:17\n", location: XPCWrappedNative_NoHelper }

columnNumber: 0

data: null

filename: "chrome://messenger/content/messengercompose/MsgComposeCommands.js"

lineNumber: 401

location: XPCWrappedNative_NoHelper { QueryInterface: QueryInterface(), filename: Getter, name: Getter, … }

message: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIEditor.getInlineSpellChecker]"

name: "NS_ERROR_FAILURE"

result: 2147500037

stack: "updateEditableFields@chrome://messenger/content/messengercompose/MsgComposeCommands.js:401:38\nToggleWindowLock@chrome://messenger/content/messengercompose/MsgComposeCommands.js:2654:23\nComposeProcessDone@chrome://messenger/content/messengercompose/MsgComposeCommands.js:680:21\n_doFcc2/<@resource:///modules/MessageSend.jsm:962:12\nnotify@resource://gre/modules/Timer.jsm:62:17\n"

<prototype>: ExceptionPrototype { toString: toString(), name: Getter, message: Getter, … }
MsgComposeCommands.js:401
updateEditableFields chrome://messenger/content/messengercompose/MsgComposeCommands.js:401
ToggleWindowLock chrome://messenger/content/messengercompose/MsgComposeCommands.js:2654
ComposeProcessDone chrome://messenger/content/messengercompose/MsgComposeCommands.js:680
_doFcc2 resource:///modules/MessageSend.jsm:962
notify resource://gre/modules/Timer.jsm:62

Please see my earlier comment. You still haven't explained what the problem is.
"Expected results: CC: / BCC: dialog should open" - is not a valid request. We never open any dialog for those, and never have.

(In reply to Magnus Melin [:mkmelin] from comment #3)

Cc/Bcc never opens any dialog - it's just about revealing those fields.
But, you need to click it - typing "CC:" doesn't do anything.

TB is now 91.0.2 (64)
You are right: I click CC/BCC, but the fields are not displayed.

Tried Help | Troubleshoot mode ?

Attached image noS_CC.png

click CC: - not saved before

Attached image afterS_CC.png

click CC: - saved before

Attached image noS_BCC.png

click BCC: - not saved before

Attached image afterS_BCC.png

click BCC: - saved before

I don't see the problem. When the cc/bcc field is already visible below, the button is not shown (because it would do nothing). If you remove the bcc, the button is again visible, like it should so that you can make it visible if you want.

I remember me:

I type a part of an new message.
Then I press Ctrl+S [Strg+S] WindowsWide-Safe-Shortcut/Command (a draft then is created)
After I try to click CC: / BCC: - This then does not work. Any new field will not be visible now.

And the fields TO: and Subject: are also no longer editable now. Until I reopen the saved draft.

The complete HEAD of message is no longer editable / write protected after i use the WIN-"Save"-command.

Ah, I see now. Bug 1726280.
(Save does the "Send" process basically, during which those buttons are disabled, and you get an error during the process to they never re-enable)

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1726280

(In reply to Magnus Melin [:mkmelin] from comment #17)

Ah, I see now. Bug 1726280.
*** This bug has been marked as a duplicate of bug 1726280 ***

Great find!

You need to log in before you can comment on or make changes to this bug.