Closed Bug 1726280 Opened 1 month ago Closed 29 days ago

Exception in call to nsIEditor.getInlineSpellChecker prevents onBeforeSend listeners working properly

Categories

(Thunderbird :: Add-Ons: Extensions API, defect, P1)

Tracking

(thunderbird_esr9193+ fixed, thunderbird92 fixed)

RESOLVED FIXED
93 Branch
Tracking Status
thunderbird_esr91 93+ fixed
thunderbird92 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(1 file)

With no dictionaries, calling GetCurrentEditor().getInlineSpellChecker(true) in updateEditableFields throws an exception. I don't think it's supposed to but let's catch the exception and carry on with life.

This is a separate bug from the reported crashes and hangs because neither of these things happen. Not to me anyway.

This exception's preventing everything beyond it from running. I don't think it's supposed to throw but it is, so let's catch the exception.

Tested by removing the dictionary from a build and running browser_ext_compose_onBeforeSend.js.

See Also: → 1725576

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/2ad3231a1fca
Catch exception in call to nsIEditor.getInlineSpellChecker. r=john.bieling

Status: ASSIGNED → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED

Comment on attachment 9236761 [details]
Bug 1726280 - Catch exception in call to nsIEditor.getInlineSpellChecker. r=john.bieling

[Approval Request Comment]
Regression caused by (bug #): bug 1695923, maybe, could be something else
User impact if declined: some types of extensions + no dictionaries installed = unable to send mail
Testing completed (on c-c, etc.): landed last week
Risk to taking this patch (and alternatives if risky): no, it's just a try/catch block

Attachment #9236761 - Flags: approval-comm-beta?

Comment on attachment 9236761 [details]
Bug 1726280 - Catch exception in call to nsIEditor.getInlineSpellChecker. r=john.bieling

[Triage Comment]
Approved for beta

Attachment #9236761 - Flags: approval-comm-beta? → approval-comm-beta+

This is desperately needed on ESR. Geoff, could you request uplift?

Flags: needinfo?(geoff)

Comment on attachment 9236761 [details]
Bug 1726280 - Catch exception in call to nsIEditor.getInlineSpellChecker. r=john.bieling

[Approval Request Comment]
Regression caused by (bug #): bug 1695923, maybe, could be something else
User impact if declined: some types of extensions + no dictionaries installed = unable to send mail
Testing completed (on c-c, etc.): landed last week
Risk to taking this patch (and alternatives if risky): no, it's just a try/catch block

Flags: needinfo?(geoff)
Attachment #9236761 - Flags: approval-comm-esr91?
Duplicate of this bug: 1726763

Comment on attachment 9236761 [details]
Bug 1726280 - Catch exception in call to nsIEditor.getInlineSpellChecker. r=john.bieling

[Triage Comment]
Approved for esr91

Attachment #9236761 - Flags: approval-comm-esr91? → approval-comm-esr91+
You need to log in before you can comment on or make changes to this bug.