Closed Bug 1728158 Opened 1 year ago Closed 1 year ago

Fail to import .ics file that contains both VEVENT and VTODO

Categories

(Calendar :: Import and Export, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1727938

People

(Reporter: richard.leger, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, regressionwindow-wanted, Whiteboard: beta)

In calendar view, with local calendars, it seems that if .ics file to import contains both VEVENT and VTODO, during import no items are imported (none appears detected in the import wizard).

Steps to reproduce in TB 91.0.3 (64-bit) on Windows 10:

  • create a new user profile
  • cancel wizard to create a new email account
  • go to calendar view
  • create a new local calendar Test1
  • add three calendar items (VEVENT) - e.g: two meetings and one daily event
  • go to task view
  • in the same calendar Test1, create a couple of tasks (VTODO)
  • go back to calendar view
  • right click Test1 calendar
  • select Export Calendar
  • save Test1.ics file
  • create a new local calendar Test2
  • go to menu > Events and Tasks > Import...
  • select the Test1.ics file previously saved and open it
  • the import wizard appears and no items are detected in the .ics file
  • pressing Import All button

Result:

  • No items are imported - VEVENT nor VTODO - calendar remains empty

Expected:

  • All items (VEVENT and VTODO) to be detected (in the import wizard) and imported into the selected calendar during import.

Note:

If you delete all the tasks from Test1 calendar, and export again to .ics file, then during import, the VEVENT items are correctly detected and imported in selected calendar. The import issue only seems to raise if the .ics file contains both type of items (VEVENT and VTODO)

Component: General → Import and Export
Product: Thunderbird → Calendar

Duplicate of bug 1727938.

Thanks Zoe!

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1727938
You need to log in before you can comment on or make changes to this bug.