Closed Bug 1727938 Opened 2 months ago Closed 8 days ago

Importing ICS file with TODO items fails with JS error

Categories

(Calendar :: Import and Export, defect, P2)

Thunderbird 91

Tracking

(thunderbird_esr91+ affected, thunderbird92 affected, thunderbird93 affected, thunderbird94+ affected)

RESOLVED FIXED
95 Branch
Tracking Status
thunderbird_esr91 + affected
thunderbird92 --- affected
thunderbird93 --- affected
thunderbird94 + affected

People

(Reporter: zoe, Assigned: thomas8)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [enterprise-relevance])

Attachments

(2 files, 1 obsolete file)

Attached file todo.ics

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

Importing ICS file with TODO items fails with JS error.
Sample file enclosed.

Console error:
CalIcsParser.jsm:159
Uncaught (in promise) TypeError: b.startDate is undefined
setUpItemSummaries chrome://calendar/content/calendar-ics-file-dialog.js:149
setUpItemSummaries chrome://calendar/content/calendar-ics-file-dialog.js:148
onWindowLoad chrome://calendar/content/calendar-ics-file-dialog.js:78
loadEventsFromFile chrome://calendar/content/import-export.js:37
calendar-ics-file-dialog.js:149:5

https://searchfox.org/comm-central/rev/590a88f6af49f11b651fa305d94ff25f1211893d/calendar/base/content/dialogs/calendar-ics-file-dialog.js#149

Looks a bit like bug 155757.

https://github.com/Betterbird/thunderbird-patches/blob/main/91/bugs/1727938-sort-no-start-date.patch
We didn't pay attention to linting, this imports the ICS file we were given successfully.

Blocks: tb91found
Duplicate of this bug: 1727777
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 1728158

This fixes the issue for me - based on Zoe's patch. Thanks Zoe!

Assignee: nobody → bugzilla2007
Status: NEW → ASSIGNED
Attachment #9238597 - Flags: review?(geoff)

Obviously enterprise-relevant.

Severity: -- → S3
Priority: -- → P2
Whiteboard: [enterprise-relevance]
Blocks: 1728018

Comment on attachment 9238597 [details] [diff] [review]
1727938_import-vtodo-from-ics.diff

There's more date values that could be tried before giving up:
https://searchfox.org/comm-central/rev/88d88aa4086176def5c63925b9d727b593ec6b99/calendar/base/modules/utils/calViewUtils.jsm#332-335

I also don't like the variable names here, because they don't relate to a and b.

Attachment #9238597 - Flags: review?(geoff) → review-
Duplicate of this bug: 1728018
Duplicate of this bug: 1731499

Thomas, can you update the patch?

Flags: needinfo?(bugzilla2007)

Improve the comparison per Geoff's comment 6.

Thanks for the ping!

Attachment #9238597 - Attachment is obsolete: true
Flags: needinfo?(bugzilla2007)
Attachment #9245747 - Flags: review?(geoff)
Attachment #9245747 - Flags: review?(geoff) → review+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/ac0a8151ac01
Fix import of ics with VTODOs (tasks) and sort items without start date to the end. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 8 days ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
No longer blocks: 1728018
You need to log in before you can comment on or make changes to this bug.