Closed Bug 1728595 Opened 5 months ago Closed 4 months ago

The "-firefox-suggest-brand-name" string is wrongly displayed instead of "Firefox Suggest" string on RO l10n build

Categories

(Mozilla Localizations :: ro / Romanian, defect, P1)

Desktop
All

Tracking

(firefox-esr91 unaffected, firefox91 unaffected, firefox92+ verified, firefox93 verified, firefox94 verified)

VERIFIED FIXED
Tracking Status
firefox-esr91 --- unaffected
firefox91 --- unaffected
firefox92 + verified
firefox93 --- verified
firefox94 --- verified

People

(Reporter: cmuntean, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Affected Versions]:

  • Firefox Nightly 93.0a1 (Build ID: 20210901091701)

[Affected Platforms]:

  • Windows 10 x64
  • macOS 10.15.7
  • Linux Mint 20

[Prerequisites]:

[Steps to reproduce]:

  1. Open the Nightly ro l10n build.
  2. Open a New Tab page, type any keyword that will trigger a history result.
  3. Observe the "Firefox Suggest" string.

[Expected results]:

  • The "Firefox Suggest" string is correctly displayed.

[Actual results]:

  • The "-firefox-suggest-brand-name" string is displayed.

[Notes]:

  • So far I have managed to reproduce the issue only on RO build. Not sure if the issue is also reproducible on other l10n builds.
  • On other l10n builds, the "Firefox Suggest" string is correctly displayed if the string is not yet localized.
  • Attached is a screenshot of the issue.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Iteration: --- → 93.2 - Aug 23 - Sep 5
Points: --- → 2
Priority: -- → P1

flod, do you know what might be causing this? The string in the screenshot is urlbar-group-firefox-suggest defined in browser.ftl and it references the new -firefox-suggest-brand-name string. Both strings landed in 93 in bug 1725289.

I don't understand why this would be a problem for ro but not other locales.

One possible complication is the caching we're doing: The first time urlbar-group-firefox-suggest is needed, we use document.l10.formatMessages to format it, we cache the formatted value, and we always use the cached value after that. Is there a chance formatMessages is not properly formatting the string?

Flags: needinfo?(francesco.lodolo)
Keywords: regression
Regressed by: 1725289

That is the expected behavior when referencing brand names, because they "translated" the string but not the brand name itself, so it doesn't fall back to English just for the brand name.
https://transvision.flod.org/?recherche=firefox-suggest-brand-name&repo=gecko_strings&sourcelocale=en-US&locale=ro&search_type=strings_entities

It will be fixed as soon as they translate the brand name.

Flags: needinfo?(francesco.lodolo)

This is an edge case, and known behavior. I think it should be either closed as INVALID (as we normally close bugs around incomplete localization), or moved to Mozilla Localizations::Romanian.

For example, Arabic didn't translate any of those strings, and correctly shows "Firefox Suggest".

Thanks flod. I'll move it to Mozilla Localizations::Romanian to be on the safe side, so it's on their radar at least. We can always close it later.

Assignee: adw → nobody
Status: ASSIGNED → NEW
Iteration: 93.2 - Aug 23 - Sep 5 → ---
Points: 2 → ---
Component: Address Bar → ro / Romanian
Product: Firefox → Mozilla Localizations
Version: Trunk → unspecified

Flod, can we get a translation fix before we ship the feature? It seems that the entity should just be copied in the Romanian l10n repo? It's a technical change and not a linguistic change right?

Flags: needinfo?(francesco.lodolo)

(In reply to Pascal Chevrel:pascalc from comment #5)

Flod, can we get a translation fix before we ship the feature? It seems that the entity should just be copied in the Romanian l10n repo? It's a technical change and not a linguistic change right?

No. This feature name can be translated, so just copying over the English text is incorrect.

With that said, I did remove the translation for the URL label (when this bug was filed), so it should be already falling back to the English text.

Flags: needinfo?(francesco.lodolo)

(In reply to Francesco Lodolo [:flod] from comment #6)

(In reply to Pascal Chevrel:pascalc from comment #5)

Flod, can we get a translation fix before we ship the feature? It seems that the entity should just be copied in the Romanian l10n repo? It's a technical change and not a linguistic change right?

No. This feature name can be translated, so just copying over the English text is incorrect.

This is not what I suggested, I suggested to copy https://hg.mozilla.org/l10n/gecko-strings/file/default/browser/browser/browser.ftl#l546 into the Romanian repo where it is missing with the intent of falling back to English text instead of a variable name if the string doesn't get translated. If this is fixed differently this is fine, please confirm which supported versions of Firefox have the bug fixed and which haven't, thanks.

Flags: needinfo?(francesco.lodolo)

(In reply to Pascal Chevrel:pascalc from comment #7)

This is not what I suggested, I suggested to copy https://hg.mozilla.org/l10n/gecko-strings/file/default/browser/browser/browser.ftl#l546 into the Romanian repo where it is missing with the intent of falling back to English text instead of a variable name if the string doesn't get translated.

What you're suggesting is what caused this bug in the first place.

If this is "translated" in the Romanian repository

urlbar-group-firefox-suggest =
  .label = { -firefox-suggest-brand-name }

But the term referenced in the string it's not translated (or available in that locale), Fluent stops the fallback chain, and shows the term ID. By removing that string, Fluent falls back for both the string and the term.

The string was removed when the bug was filed, so it's already fixed in current beta and nightly.
https://hg.mozilla.org/l10n-central/ro/rev/a441efc933c4fda3bfd588ceeee76eb157d6ffa4

Flags: needinfo?(francesco.lodolo)

(In reply to Francesco Lodolo [:flod] from comment #8)

The string was removed when the bug was filed, so it's already fixed in current beta and nightly.
https://hg.mozilla.org/l10n-central/ro/rev/a441efc933c4fda3bfd588ceeee76eb157d6ffa4

Ok, so this is not fixed in 92, ryan fyi.

92 should not be affected, since Firefox Suggest is enabled only for en-* on that version (bug 1729591).

Doesn't sound like any immediate action is needed for 92, but let's leave the bug open for now to verify once the 92.0.1 build is created with all the Suggest patches included.

Flags: needinfo?(ryanvm)
  • I have verified that this issue is no longer reproducible across platforms Windows 10 x64, macOS 10.15.7, and Linux Ubuntu 20.04 x64.
  • On the 92.0.1 Candidate, ro build (Build ID: 20210922161155), the Firefox Suggest label is not displayed when typing history/bookmarks keywords in the Address Bar. (see also bug 1729591).
  • On the Nightly 94.0a1 (Build ID: 20210923095548) and Beta 93.0b8 (Build ID: 20210921185902), both ro builds, the Firefox Suggest label is displayed when typing history/bookmarks keywords in the Address Bar.
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.