Closed Bug 1729472 Opened 19 days ago Closed 12 days ago

Perma devtools/client/performance-new/test/browser/browser_interaction-between-interfaces.js | undefined assertion name - missing "Native Stacks" when Gecko 94 merges to Beta on 2021-10-04

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P2)

defect

Tracking

(firefox-esr78 unaffected, firefox-esr91 unaffected, firefox92 unaffected, firefox93 unaffected, firefox94+ verified)

VERIFIED FIXED
94 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 + verified

People

(Reporter: aryx, Assigned: julienw)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

The issue only affects devtools on macOS - in the Beta config, DevEdition is not affected.

Native Stacks is missing from these:

12:21:38 INFO - TEST-UNEXPECTED-FAIL | devtools/client/performance-new/test/browser/browser_interaction-between-interfaces.js | undefined assertion name - Got "Interval: 2 ms\nThreads: GeckoMain, Compositor, Renderer, DOM Worker\nScreenshots\nJavaScript\nNative Leaf Stack\nCPU Utilization", expected "Interval: 2 ms\nThreads: GeckoMain, Compositor, Renderer, DOM Worker\nScreenshots\nJavaScript\nNative Leaf Stack\nNative Stacks\nCPU Utilization"
12:21:38 INFO - TEST-UNEXPECTED-FAIL | devtools/client/performance-new/test/browser/browser_interaction-between-interfaces.js | undefined assertion name - Got "Interval: 2 ms\nThreads: GeckoMain, Compositor, Renderer, DOM Worker, StyleThread\nScreenshots\nJavaScript\nNative Leaf Stack\nCPU Utilization", expected "Interval: 2 ms\nThreads: GeckoMain, Compositor, Renderer, DOM Worker, StyleThread\nScreenshots\nJavaScript\nNative Leaf Stack\nNative Stacks\nCPU Uti
12:21:38 INFO - TEST-UNEXPECTED-FAIL | devtools/client/performance-new/test/browser/browser_interaction-between-interfaces.js | undefined assertion name - Got "Interval: 2 ms\nThreads: GeckoMain, Compositor, Renderer, DOM Worker\nScreenshots\nJavaScript\nNative Leaf Stack\nCPU Utilization", expected "Interval: 2 ms\nThreads: GeckoMain, Compositor, Renderer, DOM Worker\nScreenshots\nJavaScript\nNative Leaf Stack\nNative Stacks\nCPU Utilization"
12:21:38 INFO - TEST-UNEXPECTED-FAIL | devtools/client/performance-new/test/browser/browser_interaction-between-interfaces.js | undefined assertion name - Got "Interval: 2 ms\nThreads: GeckoMain, Compositor, StyleThread, DOM Worker\nScreenshots\nJavaScript\nNative Leaf Stack\nCPU Utilization", expected "Interval: 2 ms\nThreads: GeckoMain, Compositor, StyleThread, DOM Worker\nScreenshots\nJavaScript\nNative Leaf Stack\nNative Stacks\nCPU Utilization"

Changing severity to S4 because users are not impacted.

Severity: -- → S4
Priority: -- → P2
Assignee: nobody → felash

(In reply to Julien Wajsberg [:julienw] from comment #2)

Here is a try for early beta: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f48c0e3d22a1454e86682bd69f260b47223115db
And another one for late beta: https://treeherder.mozilla.org/#/jobs?repo=try&revision=69c79fa527ffd152117a959d9257d3df733350ce

These try builds are completely busted for unrelated reasons... Is that known Sebastian? Any idea to fix this on my end?

Flags: needinfo?(aryx.bugmail)

The patch from bug 1729689 is needed to unbust these simulations (should be in central on Friday).

Flags: needinfo?(aryx.bugmail)
Attachment #9240247 - Attachment description: WIP: Bug 1729472 - [devtools performance] Adapt the multi-panel interaction tests so that they work in environments where some features are missing r=jdescottes! → Bug 1729472 - [devtools performance] Adapt the multi-panel interaction tests so that they work in environments where some features are missing r=jdescottes!

Try after rebasing on top of latest central (because I updated some tests in this area): https://treeherder.mozilla.org/#/jobs?repo=try&revision=ab3624bf3243c1c203f6d6d51cf5e8bef5a101db

They're not exactly the same tests (they're not "shippable"), but the tests in the "debug" build were showing the same issues previously.

Applying the patch in latest beta sim made the failures go away

Pushed by jwajsberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/596b3eff1c15
[devtools performance] Adapt the multi-panel interaction tests so that they work in environments where some features are missing r=jdescottes
Backout by ctuns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1e862f7b2cd6
Backed out changeset 596b3eff1c15 for causing mochitest failures on browser_headless_screenshot_1/2.js. CLOSED TREE
Pushed by ctuns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/11d3a5026dea
[devtools performance] Adapt the multi-panel interaction tests so that they work in environments where some features are missing r=jdescottes. CLOSED TREE

The issue wasn't from there it got relanded.

Status: NEW → RESOLVED
Closed: 12 days ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

Verified fixed in today's central-as-beta simulation.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.