Tab prefs should allow changing new tab contents

VERIFIED DUPLICATE of bug 187573

Status

()

Firefox
Preferences
--
enhancement
VERIFIED DUPLICATE of bug 187573
15 years ago
15 years ago

People

(Reporter: Chris Cook, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Tabbed display preferences should be enhanced to allow opening new tabs at the
home page OR blank.

This could be implemented something like:

Place, in the "Tab Display" area, a checkbox labeled "Open new tabs with Home
Page".  If this option is checked then the home page is loaded.  If unchecked
then the new tab is loaded blank.

This is a quick and seemingly easy and possibly shortsighted enhancement.  Other
requesters have mentioned opening tab-groups or other fancier behaviors.  An
alternative implementation to support these, and consequently make the prefs UI
or complicated could be:

Create a new area called "New Tabs" and basically duplicate the UI options used
in General for home page.

I am aware that this capability is currently available via a browser extension
but this feature seems too closely tied to browser tabs to leave to an extension
and other browsers that support tabs have much more flexible implentations of
tabs than current releases of phoenix or mozilla.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 170946 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
This bug is not a dupe of 170946.  I have waited to see if the results of bug
170946 would miraculously provide the suggested functionality but that hasn't
happened.

I will succinctly rephrase my request. Please consider it.

Browser tabs currently open with "about:blank" as the contents. There should be
an option to allow new tabs to open with the home page as the contents.

I have implemented this myself with less than 10 lines of code changes (in 3
files) and I would be happy to provide modified files (or a patch with
assistance). My solution consisted of adding a checkbox option to the "Tabbed
browsing" pref.  I am aware this capability exists via a browser extension but I
believe it should be in the browser.  Please mark this as wontfix or use it, but
it isn't a dupe (of 170946 anyway).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

15 years ago
Yeah, I know, it's being duped against a later bug...

*** This bug has been marked as a duplicate of 187573 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.