Last Comment Bug 187573 - Pref(s) to set what new tabs and windows display
: Pref(s) to set what new tabs and windows display
Status: RESOLVED DUPLICATE of bug 174184
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: unspecified
: x86 All
: -- enhancement with 5 votes (vote)
: ---
Assigned To: Blake Ross
:
Mentors:
: 172976 194522 226211 249355 252919 252999 253256 254888 255629 264778 266767 267114 275355 286634 289443 311680 318390 329378 335888 360178 477229 491181 577660 614923 634870 686856 (view as bug list)
Depends on:
Blocks: 164421
  Show dependency treegraph
 
Reported: 2003-01-03 08:20 PST by Emery Finkelstein
Modified: 2013-07-27 01:53 PDT (History)
31 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Emery Finkelstein 2003-01-03 08:20:49 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

Currently Pheonix opens the new window to the set homepage. I am used to the
Internet Explorer way of things where Ctrl+N brings up another window with the
same url location as that of the one in which Ctrl+ was used.

Also this lack of feature applies to the Ctrl+t shortcut to open a new tab,
but in the case of new tab, the new tab is initialized to a blank page.

I would like to see a feature added to the Pheonix preferences, that allows you
to  choose how Pheonix reacts to the new window and new tab shortcuts, Ctrl+N
and Ctrl+T. 

If this is not possible perhaps a second shortcut that has this effect.
This may already exist, but I'm not sure, as I don't have a list of shortcuts
available to me.


Reproducible: Always

Steps to Reproduce:
1.Ctrl + N or Ctrl + T while a Phenoix window/tab is the active window.
2.
3.

Actual Results:  
Phenoix opens a new window to my homepage, or Pheonix creates a new tab with a
blank page loaded.

Expected Results:  
This is a matter of preference, I'd prefer that the new tabs/windows be
initialed to the same url as the active window/tab when the shortcuts (Ctrl+N or
Ctrl+T) are invoked.
Comment 1 David P James 2003-01-03 15:21:30 PST
I see. To each his own I suppose.

I'm going to have to change the summary on this though.

From:
New window with Ctrl+N always opens to home page
to:
Pref to set URL to that of active tab when Ctrl+[N,T] is invoked

-->OS to All (enhancements, unless OS specific, should always be ALL)
-->Confirming for developer review
Comment 2 Michael Newton 2003-01-03 16:15:15 PST
maybe there should be 3 options determining the behaviour:
1. Blank window/tab
2. New window/tab with home page
3. New window/tab with duplicate of current tab
Comment 3 David P James 2003-01-12 10:25:10 PST
Try installing the tabbed browsing extension;

http://texturizer.net/phoenix/extensions.html#tabbed

There is a preference there for new tabs at least.
Comment 4 David P James 2003-01-22 05:34:29 PST
*** Bug 172976 has been marked as a duplicate of this bug. ***
Comment 5 David P James 2003-01-22 05:58:54 PST
Ok, sorry for the bugspam again. Let's clean this up a bit. What seems to be
desired is a set of prefs to determine what new tabs and new windows should
display (comment #2, bug 172976).

-->Changing summary (again)
Comment 6 Asa Dotzler [:asa] 2003-02-01 21:28:57 PST
Phoenix developers won't be implementing this in Phoenix. 
Comment 7 David P James 2003-02-22 21:16:33 PST
*** Bug 194522 has been marked as a duplicate of this bug. ***
Comment 8 Mike Connor [:mconnor] 2003-07-28 11:50:36 PDT
taking QA contact, sorry about the bugspam
Comment 9 Brant Gurganus 2003-08-09 09:33:00 PDT
VERIFYING obvious WONTFIX bugs.  Filter on firebirdWontFix to filter these bugs.
 I skipped a few that I'm unsure about from their summary and will manually go
through them.
Comment 10 Jon Henry 2003-11-19 08:14:07 PST
*** Bug 226211 has been marked as a duplicate of this bug. ***
Comment 11 Mike Connor [:mconnor] 2004-04-18 09:04:37 PDT
*** Bug 240868 has been marked as a duplicate of this bug. ***
Comment 12 Zach Spoelstra 2004-07-01 05:38:05 PDT
*** Bug 249355 has been marked as a duplicate of this bug. ***
Comment 13 Bogdan Stroe 2004-07-24 15:28:03 PDT
*** Bug 252919 has been marked as a duplicate of this bug. ***
Comment 14 Carlos Ribeiro 2004-07-25 16:13:28 PDT
I've filled bug #252999 for a similar complaint. It was suggested that my
#252999 to be with this one. If you are going to merge both bugs, please make
sure that this one is going to be rechecked, or at least that it stands a chance
at being removed from the WONTFIX status.
Comment 15 Mike Connor [:mconnor] 2004-07-25 21:04:25 PDT
*** Bug 252999 has been marked as a duplicate of this bug. ***
Comment 16 Bill Mason 2004-07-27 09:08:00 PDT
*** Bug 253256 has been marked as a duplicate of this bug. ***
Comment 17 Jesse Ruderman 2004-08-16 14:34:27 PDT
*** Bug 255629 has been marked as a duplicate of this bug. ***
Comment 18 Gary van der Merwe 2004-10-26 04:03:18 PDT
*** Bug 264778 has been marked as a duplicate of this bug. ***
Comment 19 Jo Hermans 2004-10-29 15:49:44 PDT
*** Bug 266767 has been marked as a duplicate of this bug. ***
Comment 20 Phil Ringnalda (:philor) 2004-11-06 23:11:16 PST
*** Bug 267114 has been marked as a duplicate of this bug. ***
Comment 21 Tom Gallant 2004-11-15 23:49:28 PST
With now 12 entries/votes for this one, _please_ re-instate for Firefox!
Comment 22 Mike Connor [:mconnor] 2004-11-16 06:07:25 PST
just because 12 people out of a user community in the millions want a feature
doesn't mean we're going to do it.  Advocacy comments don't help either.  There
were prefs that used to work for this that we've explicitly removed in the last
few months because we don't feel these prefs are generally necessary or useful.
 However, that being said, Ctrl-N cloning the current tab in a new window (a la
IE) is probably more useful than the home page, and is still an open bug IIRC. 
That wouldn't be a pref though, it would be a change in the behaviour.

This is solely for informational/clarification purposes.  Arguing about it in
the bug won't accomplish much.
Comment 23 Matthias Versen [:Matti] 2004-12-20 15:46:28 PST
*** Bug 275355 has been marked as a duplicate of this bug. ***
Comment 24 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-03-17 14:55:59 PST
*** Bug 286634 has been marked as a duplicate of this bug. ***
Comment 25 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-03-18 11:01:05 PST
*** Bug 254888 has been marked as a duplicate of this bug. ***
Comment 26 Kevin Brosnan 2005-04-07 09:09:43 PDT
*** Bug 289443 has been marked as a duplicate of this bug. ***
Comment 27 Marc Bejarano 2005-05-28 12:09:29 PDT
fyi: the Clone Window extension from
http://www.pikey.me.uk/mozilla/?extension=cw provides the requested functionality.

emery (or other empowered reader): can you link to this comment from the Status
Whiteboard?
Comment 28 Dave Townsend [:mossop] 2005-10-08 09:32:10 PDT
*** Bug 311680 has been marked as a duplicate of this bug. ***
Comment 29 Dave Townsend [:mossop] 2005-11-30 14:27:43 PST
*** Bug 318390 has been marked as a duplicate of this bug. ***
Comment 30 Ryan Flint [:rflint] (ping via IRC for reviews) 2006-03-04 17:39:11 PST
*** Bug 329378 has been marked as a duplicate of this bug. ***
Comment 31 Ria Klaassen (not reading all bugmail) 2006-04-29 02:15:32 PDT
*** Bug 335888 has been marked as a duplicate of this bug. ***
Comment 32 Mike Connor [:mconnor] 2006-08-27 05:58:27 PDT
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
Comment 33 Phil Ringnalda (:philor) 2006-11-09 15:43:48 PST
*** Bug 360178 has been marked as a duplicate of this bug. ***
Comment 34 Ria Klaassen (not reading all bugmail) 2009-02-06 06:21:57 PST
*** Bug 477229 has been marked as a duplicate of this bug. ***
Comment 35 deepa 2009-04-07 03:42:56 PDT
dkvgfladjbvgjksdgvfyugb
Comment 36 Matthias Versen [:Matti] 2009-05-03 23:00:46 PDT
*** Bug 491181 has been marked as a duplicate of this bug. ***
Comment 37 Kevin Brosnan [:kbrosnan] 2011-02-17 04:54:10 PST
*** Bug 634870 has been marked as a duplicate of this bug. ***
Comment 38 Robert Longson 2011-09-15 03:28:39 PDT
*** Bug 686856 has been marked as a duplicate of this bug. ***
Comment 39 Robert Longson 2011-09-15 03:29:34 PDT
*** Bug 614923 has been marked as a duplicate of this bug. ***
Comment 40 Enrique Moreno Tent 2011-09-15 03:54:16 PDT
(In reply to Asa Dotzler [:asa] from comment #6)
> Phoenix developers won't be implementing this in Phoenix.

What kind of argument is this???
Comment 41 Dão Gottwald [:dao] 2013-07-27 01:50:24 PDT
*** Bug 577660 has been marked as a duplicate of this bug. ***
Comment 42 Dão Gottwald [:dao] 2013-07-27 01:53:39 PDT

*** This bug has been marked as a duplicate of bug 174184 ***

Note You need to log in before you can comment on or make changes to this bug.