Closed Bug 1730309 Opened 5 months ago Closed 4 months ago

Tooltip is shown doubly on hover over the maximize button

Categories

(Firefox :: Theme, defect)

defect

Tracking

()

VERIFIED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 + verified
firefox95 --- verified

People

(Reporter: emk, Assigned: cmartin)

References

(Regressed 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Steps to reproduce:
Hover the mouse cursor over the maximize button.

Actual result:
On Windows 10, two "Maximize" tooltips are shown.
On Windows 11, both tooltip and Snap Layouts menu will be shown.

Expected result:
Only single tooltip or Snap Layouts menu should be shown.

We should stop showing "Maximize" tooltip on our own. The operating system will do it for us.

Attached image screenshot

Screenshot of Nightly94.0a1 en-US build on Windows10 Home Japanese Lang pack.

Yes, double tootip 最大化 and Maximize.

Set release status flags based on info from the regressing bug 1729742

Assignee: nobody → davidp99

Since bug 1718629, Gecko has used Windows behavior around the maximize button, in order to support Windows 11's snap layouts view. The Windows behavior always shows a Maximize tooltip on that button so Gecko's tooltip was making for two Maximize tooltips.

Attachment #9241254 - Attachment description: Bug 1730309: Remove tooltip from maximize window button on Windows r=emk! → Bug 1730309: Part 1 - Use Windows behavior for minimize and close buttons r=emk!,emilio!

Windows will show the tooltips for these buttons so we don't want to also show Gecko's.

Depends on D125625

Taking over this bug because David Parks is away indefinitely

Assignee: davidp99 → cmartin
Status: NEW → ASSIGNED
Pushed by cmartin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/35fc365ef200
Part 1 - Use Windows behavior for minimize and close buttons r=emk,emilio
https://hg.mozilla.org/integration/autoland/rev/231dfa18e7e8
Part 2 - Skip tooltips for window buttons on Windows r=emilio
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

Hi Chris, is this ready for a Beta approval nomination?

Flags: needinfo?(cmartin)

Comment on attachment 9241254 [details]
Bug 1730309: Part 1 - Use Windows behavior for minimize and close buttons r=emk!,emilio!

Beta/Release Uplift Approval Request

  • User impact if declined: Maximize button will continue to show double-tooltip
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Most of the risk from this comes from its lack of automated testing, and the fact that it does represent a change in how we handle the min/max/close buttons. But it seems like if it was going to fail basic sanity than it would be obvious quickly, so that's why the risk still seems pretty low.
  • String changes made/needed:
Flags: needinfo?(cmartin)
Attachment #9241254 - Flags: approval-mozilla-beta?
Attachment #9241457 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9241254 [details]
Bug 1730309: Part 1 - Use Windows behavior for minimize and close buttons r=emk!,emilio!

Approved for 94.0b4. Given that this is already a regression fix from previous work and we have minimal test coverage, I think we should get additional QA testing around this, however.

Attachment #9241254 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9241457 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Reproduced the issues described in comment 0, on both, Win 10 x64 and Win 11 using an affected Nightly build (94.0a1 2021-09-10).

The issue is not reproducible anymore on the latest builds running Win 10: Nightly 95.0a1 and Beta 94.0b4.

On Win 11, it seems that the tooltip is still shown while slowly hovering over the maximize button, as seen in this screencast. This was checked with 94.0b4 en-US build, with Japanese lang pack installed and set as primary language. Can you please take a look at this, Chris?

Flags: needinfo?(cmartin)
See Also: → 1735209

(In reply to Ciprian Georgiu [:ciprian_georgiu], Release Desktop QA from comment #12)

On Win 11, it seems that the tooltip is still shown while slowly hovering over the maximize button, as seen in this screencast. This was checked with 94.0b4 en-US build, with Japanese lang pack installed and set as primary language. Can you please take a look at this, Chris?

I do not see this issue on Windows 11 using English. This is almost certainly something unexpected with the localization. Filed as bug 1735209.

(In reply to Ciprian Georgiu [:ciprian_georgiu], Release Desktop QA from comment #12)

On Win 11, it seems that the tooltip is still shown while slowly hovering over the maximize button, as seen in this screencast. This was checked with 94.0b4 en-US build, with Japanese lang pack installed and set as primary language. Can you please take a look at this, Chris?

Could you attach the screencast to Bugzilla or anywhere visible from non-Mozilla-employees?

Flags: needinfo?(ciprian.georgiu)

Comment on attachment 9245350 [details]
screencast from comment 12

I attached the screencast to bug 1735209.

Attachment #9245350 - Attachment is obsolete: true

(In reply to David Parks [:handyman] from comment #13)

I do not see this issue on Windows 11 using English. This is almost certainly something unexpected with the localization. Filed as bug 1735209.

Thanks. Yes, I can also confirm that the issue is not present when running Windows 11 English version. Tested with latest Nightly 95.0a1 and Beta 94.0b4.

I'm going to close this bug as verified fixed per this comment, and my previous one.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(cmartin)
Regressions: 1736128

I think the OS tooltip is pretty bad on Windows 10. It's yellow, it can't be customized profitably without a lot of hackery, it disappears after like 3-5 seconds, it doesn't obey any of the internal settings like ui.tooltipDelay and it has a fade transition inconsistent with Firefox's DOM tooltips. I understand the other changes but why use the OS tooltip when tabsintitlebar is enabled and every other element in the chrome window with a tooltip uses a DOM tooltip or the generic native-anonymous one?

Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.