Closed Bug 1732506 Opened 2 months ago Closed 2 months ago

Firefox UI language changes after updating to 92.0.1

Categories

(Firefox :: General, defect)

Firefox 92
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox92 blocking fixed

People

(Reporter: sleipnir, Assigned: jcristau)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0

Steps to reproduce:

Since version 92.0.1 (64-Bit) the language of the menus is fixed to English.

Actual results:

Settings in Tools->Settings->General have no effect. I set it (back) to German, restarted Firefox, but the language is still in English.

Expected results:

Menu language should be German.

Please go to about:support, copy the RAW data, then attach it here in the bug (use the "Attach New File" button, then paste the data from your clipboard).

Flags: needinfo?(sleipnir)
Attached file Raw data

Looks like you're running an English build with German language pack on top.

  1. Open about:addons, Languages section, try manually searching for updates to the add-ons. Then restart and see if anything changes.
  2. If that still doesn't work, from about:support try clearing the start-up cache (it's internal cache, nothing to do with browsing cache, there's no data loss).

The language pack in your about:support data is older than it should (the latest version is 92.0buildid20210922161155, you have 92.0buildid20210903235534). Still, since it's a 92.* language pack it shouldn't create any issue, and their content should be exactly the same.

I reinstalled the language pack (delete, restart, add from https://addons.mozilla.org/de/firefox/addon/deutsch-de-language-pack/). The language is back to German. Everything fine.

Thanks a lot!

Flags: needinfo?(sleipnir)

Out of curiosity, those two steps I suggested didn't work or did you go directly for the reinstall?

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME

They didn't have any effect, sorry. But sending me to about:addons and mentionig "German language pack" set me on the right path.
Thanks again.

I am reopening because we seem to have multiple reports about this bug in German forums (see the discussion with Sören in the #release-drivers channel on Element).

I am also seeing several people discussing that same issue in French forums: https://forums.mozfr.org/viewtopic.php?f=5&t=146908

There may be something funky that happened with the 92.0.1 update and langpacks. Ryan fyi.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---

I think that the language pack not updating when Firefox moves from 92 to 92.0.1 is expected, because bug 1566084 would kick in only for major updates (but would be good to confirm).

I double checked the language packs, which I assumed would be identical. They're not.

$ diff -r deutsch_de_language_pack-92.0buildid20210903235534-fx/ deutsch_de_language_pack-92.0buildid20210922161155-fx/
Only in deutsch_de_language_pack-92.0buildid20210922161155-fx/browser/localization/de/preview: firefoxSuggest.ftl
diff -r deutsch_de_language_pack-92.0buildid20210903235534-fx/manifest.json deutsch_de_language_pack-92.0buildid20210922161155-fx/manifest.json
13c13
<   "version": "92.0buildid20210903235534",
---
>   "version": "92.0buildid20210922161155",

The most recent language pack has browser/localization/de/preview/firefoxSuggest.ftl, which is surprising to me. I thought FTL files not exposed to localization (in preview) would not be packaged in locales, only en-US.
https://hg.mozilla.org/mozilla-central/rev/7b4db2f1bf8f241eb9b4be4554d151331516a5ac

So, this might be falling back to English because the file is missing with the older language pack (bug 1464156).

At this point, I don't think there's much that we can do for 92. I'm surprised manually searching for updates in about:addons doesn't work though.

Duplicate of this bug: 1732561
Summary: language of the menus is fixed to English → Firefox UI language changes after updating to 92.0.1

I just tested manually installing an outdate language pack for es-ES
https://addons.mozilla.org/firefox/addon/espa%C3%B1ol-espa%C3%B1a-language-pac/versions/

Indeed, searching for updates doesn't find the most recent version. Why?

For users affected: reinstalling the language pack should work.

  1. Open this page https://addons.mozilla.org/firefox/language-tools/
  2. Select the language pack link for the language you want
  3. Click the Remove button, then Add to Firefox

The language should be active immediately, without need to restart.

My initial read is that this caused by this:

The most recent language pack has browser/localization/de/preview/firefoxSuggest.ftl, which is surprising to me. I thought FTL files not exposed to localization (in preview) would not be packaged in locales, only en-US.

So, between 92.0.0 and 92.0.1 we added a new file and hooked it into preferences.xhtml and browser.xhtml. Two main UIs. And then we do not trigger language pack update between them, so we put users in scenario where their l10n contexts are incomplete.

So, this might be falling back to English because the file is missing with the older language pack (bug 1464156).

This could be a solution but it will require careful consideration of consequences of building incomplete FluentBundles. One could treat "missing file" the same way as empty, technically it wouldn't be hard, but I'm uncertain of how it would impact the model of partial translations etc.
Maybe with the meta-source that Daniel implemented in bug 1642415 it is now more viable?

Alternatively we could be a bit more stricter about minimizing l10n changes between minor releases and/or pushing minor updates of langpacks to users a bit more aggressively.

(In reply to Zibi Braniecki [:zbraniecki][:gandalf] from comment #12)

So, between 92.0.0 and 92.0.1 we added a new file and hooked it into preferences.xhtml and browser.xhtml. Two main UIs. And then we do not trigger language pack update between them, so we put users in scenario where their l10n contexts are incomplete.

Correct, but they're not in the standard path for l10n files, they're only for en-US. So, I wrongly assumed we wouldn't look for them in a locale (e.g. German), and they wouldn't affect the fallback chain.

Alternatively we could be a bit more stricter about minimizing l10n changes between minor releases and/or pushing minor updates of langpacks to users a bit more aggressively.

I'm surprised about the language pack not updating, but I guess that's because AMO treats language packs like any other add-ons, and buildid{DATE} is treated like some sort of beta version. I tried to find more info, but couldn't find any information on AMO's logic around that.

I don't understand what you guys are talking about, but I appreciate your effort :-)
Do you need any more information or tests from me?

(In reply to Eldkatten from comment #14)

I don't understand what you guys are talking about, but I appreciate your effort :-)
Do you need any more information or tests from me?

No need, thanks. The root cause of the problem is known, the question is how to mitigate while we wait for 93 to be released.

Depends on: 1732676

Updates to 92.0.1 have been halted while we continue to investigate solutions.

Component: Untriaged → General

I have managed to reproduce this issue using the following STR:

  1. Open Firefox 92.0 en-US build and block the updates.
  2. Install the older DE language pack for 92.0: https://ftp.mozilla.org/pub/firefox/releases/92.0/win64/xpi/de.xpi
  3. Navigate to about:preferences page, from the Language section, select the German language.
  4. Click the "Apply and Restart" button.
  5. Update the Firefox 92.0 browser to Firefox 92.0.1.

The immediate issue with 92.0.1 was fixed by updating the language packs on addons.mozilla.org with a bumped version number (and no other changes). Bug 1732676 will avoid this going forward by fixing the langpack version scheme.

Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED
Assignee: nobody → jcristau
You need to log in before you can comment on or make changes to this bug.