Closed Bug 1733500 Opened 2 months ago Closed 2 months ago

Re-enable power-efficient video playback on M1 machines for hardware-decoded video only

Categories

(Core :: Graphics: WebRender, task)

All
macOS
task

Tracking

()

VERIFIED FIXED
95 Branch
Tracking Status
firefox94 --- verified
firefox95 --- verified

People

(Reporter: mstange, Assigned: bradwerth)

References

Details

Attachments

(1 file)

We disabled it in bug 1733148 but the problems only affected software-decoded video. So we should be able to re-enable the power-efficient path for hardware-decoded video.

Currently, our runtime checks for using specialized video layers do not check the format of the video, but they could be changed to do that. That would make it possible to turn on the pref for M1 Macs safely.

Bug 1735420 added the format check, so I think we can just flip the pref back on now. Brad, do you agree?

Depends on: 1735420

(In reply to Markus Stange [:mstange] from comment #2)

Bug 1735420 added the format check, so I think we can just flip the pref back on now. Brad, do you agree?

I do, as long as we've confirmed the runtime check is working correctly on M1 Macs. Turning this back on will certainly simplify the explanation of the feature "Lower power usage for hardware decoded videos in fullscreen." Let's land an uplift this also.

I've flipped the pref and I'm not getting any kernel panics any more. And with the NV12 pref flipped and the patch from bug 1736626 applied, I'm also getting detachment for software-decoded video without kernel panics.

(In reply to Markus Stange [:mstange] from comment #4)

I've flipped the pref and I'm not getting any kernel panics any more. And with the NV12 pref flipped and the patch from bug 1736626 applied, I'm also getting detachment for software-decoded video without kernel panics.

Okay, I'll push a patch to re-enable so we can at least discuss uplift. I'm assuming Bug 1736626 will need more time to bake and so this Bug doesn't need any dependencies to also uplift (other than Bug 1735420 which was already accepted).

This is now safe and sufficient because software-encoded videos are no longer
permitted for video specialization.

Assignee: nobody → bwerth
Status: NEW → ASSIGNED
Pushed by bwerth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/83637094c30e
Enable video specialization for M1 Macs. r=mstange

Comment on attachment 9246703 [details]
Bug 1733500: Enable video specialization for M1 Macs.

Beta/Release Uplift Approval Request

  • User impact if declined: M1 Mac users will not benefit from our touted power savings for fullscreen video in FF94 without manually flipping a pref.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): We've already uplifted Bug 1735420 which handles the case that caused M1 Macs to crash with this feature turned on.
  • String changes made/needed:
Attachment #9246703 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

Verified-fixed on the latest Nightly 95.0a1 (2021-10-21) (64-bit) on MacOS M1 11.
The pref is now enabled by default.

Comment on attachment 9246703 [details]
Bug 1733500: Enable video specialization for M1 Macs.

Makes our Fx94 macOS battery life improvement story more consistent now that we can avoid the kernel panics. Approved for 94.0b9.

Attachment #9246703 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified-fixed on the latest Firefox Beta 04.0b9 on macOS 11 M1 device.
The feature is enabled for eligible hardware decoded videos from multiple sites.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.