Closed Bug 1733536 Opened 1 year ago Closed 11 months ago

Enable <dialog> element by default

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
98 Branch
Tracking Status
relnote-firefox --- 98+
firefox98 + fixed

People

(Reporter: hsinyi, Assigned: emilio, NeedInfo)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

We enabled <dialog> in nightly in bug 1645046.
This is to track enabling the dialog element by default in release builds.

What are the required changes for enabling <dialog>?

Flags: needinfo?(htsai)

(In reply to Tom Schuster [:evilpie] from comment #1)

What are the required changes for enabling <dialog>?

Per my best understanding, this accessibility issue https://github.com/whatwg/html/pull/4184 is the main blocker.
NI Emilio to confirm. :)

Flags: needinfo?(htsai) → needinfo?(emilio)

Yep, that's right, getting consensus on that issue is the main blocker afaict.

Flags: needinfo?(emilio)
Depends on: 1701230

It's been enabled on Nightly for a long while, and the only remaining
issue is about focus (https://github.com/whatwg/html/pull/4184 and co,
mostly). But:

  • We get compat reports on release / ESR because of <dialog> not being
    enabled.

  • Accessibility of hand-rolled dialogs is usually worse.

  • I don't think tweaking the focus behavior slightly will have much
    compat fallout in practice, compared to websites just assuming
    <dialog> exists and is implemented, and breaking otherwise.

So, being pragmatic, I think it's probably better to have it enabled
than not. Thoughts?

Assignee: nobody → emilio
Status: NEW → ASSIGNED

(In reply to Emilio Cobos Álvarez (:emilio) from comment #4)

Created attachment 9257348 [details]
Bug 1733536 - [rfc] Enable <dialog> by default. r=smaug!,annevk!,Jamie!,sefeng!

It's been enabled on Nightly for a long while, and the only remaining
issue is about focus (https://github.com/whatwg/html/pull/4184 and co,
mostly). But:

  • We get compat reports on release / ESR because of <dialog> not being
    enabled.

  • Accessibility of hand-rolled dialogs is usually worse.

  • I don't think tweaking the focus behavior slightly will have much
    compat fallout in practice, compared to websites just assuming
    <dialog> exists and is implemented, and breaking otherwise.

So, being pragmatic, I think it's probably better to have it enabled
than not. Thoughts?

This sounds good to me. Pulling in Romain (Firefox front end) and Asa (a11y) for sign off.

Flags: needinfo?(rtestard)
Flags: needinfo?(asa)

Another point towards getting enabled it by default is that front-end code uses it really extensively already.

Attachment #9257348 - Attachment description: Bug 1733536 - [rfc] Enable <dialog> by default. r=smaug!,annevk!,Jamie!,sefeng! → Bug 1733536 - Enable <dialog> by default. r=smaug!,annevk!,Jamie!,sefeng!
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cca392552a57
Enable <dialog> by default. r=smaug,annevk,Jamie,sefeng
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 98 Branch
No longer depends on: 1701230
Regressions: 1749503
Blocks: 1727499
Depends on: 1645046

Is that an important enough platform feature to be mentioned in the Web platform section of our general release notes in beta/Release? Thanks

Flags: needinfo?(emilio)

Yea

Flags: needinfo?(emilio)

Release Note Request (optional, but appreciated)
[Why is this notable]: Improvement to our HTML support with positive webcompat impact
[Affects Firefox for Android]: ?
[Suggested wording]: The <dialog> HTML element already available on pre-release channels will become available on the release channel in version 98.
[Links (documentation, blog post, etc)]:

I am keeping the relnote flag on this one, I added a nightly specific note for the moment that will need a rewrite once we enter beta.

relnote-firefox: --- → ?

Hello, I will be updating the docs (including the release note) for this fix. They can be tracked here: https://github.com/mdn/content/issues/12578#issuecomment-1048829230

Depends on: 1761839
You need to log in before you can comment on or make changes to this bug.