Last Comment Bug 173406 - "Open in tabs" should have a prefable option: replace vs. append
: "Open in tabs" should have a prefable option: replace vs. append
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: unspecified
: x86 Windows XP
: -- normal with 4 votes (vote)
: Phoenix0.3
Assigned To: Pierre Chanial
:
Mentors:
: 174332 175335 415874 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 20:34 PDT by David Hyatt
Modified: 2008-06-19 10:02 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description David Hyatt 2002-10-08 20:34:56 PDT
Open in tabs should do either a replace (blowing away existing tabs) or an 
append (creating a new set of tabs) based off a preference in the Tabbed 
Browsing panel.

The default for this pref should be "replace" IMO.
Comment 1 David Hyatt 2002-10-08 20:35:12 PDT
Should fix for 0.3.
Comment 2 Pierre Chanial 2002-10-11 14:21:38 PDT
fixed
Comment 3 Brant Gurganus 2003-07-18 13:17:50 PDT
REOPENED Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030714
Mozilla Firebird/0.6

I do not see the mentioned preference anywhere.
Comment 4 Brant Gurganus 2003-07-18 14:31:56 PDT
*** Bug 174332 has been marked as a duplicate of this bug. ***
Comment 5 Brant Gurganus 2003-07-18 18:30:45 PDT
*** Bug 175335 has been marked as a duplicate of this bug. ***
Comment 6 Mike Connor [:mconnor] 2003-07-24 20:28:47 PDT
This is no longer a visible pref since around February, but the pref does exist.
 If its going to be added back in, there is a bug already to restore UI for some
of these tab prefs.
Comment 7 Mike Connor [:mconnor] 2003-07-28 12:05:50 PDT
taking QA contact, sorry about the bugspam
Comment 8 James McCoy 2003-09-05 05:38:37 PDT
Is there a way this can be set via about:config until the UI option is re-added?
Comment 9 Mike Connor [:mconnor] 2003-09-05 17:09:11 PDT
I doubt UI will be re-added at this point.

browser.tabs.loadFolderAndReplace set to false does append
Comment 10 Norbert 2004-09-02 00:58:11 PDT
"Normal" Mozilla (I think it's called "Seamonkey") seems to have such a feature,
according to bug 222769.
So why not adding this to Firefox!?
Comment 11 Mike Connor [:mconnor] 2004-09-02 06:29:57 PDT
because the presence of UI for something is measured in "why" instead of "why not"

seamonkey has about ten times as many visible prefs, most of which can still be
set by users, but we removed many of them to reduce complexity.  There's still
debate on this elsewhere, resurrecting bugs that haven't had comments in a year
is pointless.
Comment 12 Mike Connor [:mconnor] 2006-08-27 06:33:23 PDT
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
Comment 13 u88484 2008-02-06 18:45:08 PST
*** Bug 415874 has been marked as a duplicate of this bug. ***
Comment 14 Christopher Smith 2008-02-08 01:22:38 PST
As the "replace" option is destructive (and there's no way to undo), "append" should be the default unless and perhaps even if a UI option is added.

More specifically, there's an easy workaround for creating the "replace" behavior (choose "Close Other Tabs" from the tab context menu), but there's no easy workaround for replacing tabs, at least not until tabs are easily movable between windows.  This is a preference that probably doesn't deserve a UI option, but "safe" behavior should be preferred if the user has to understand about:config to change it.
Comment 15 mneumark@gmail.com 2008-04-04 11:25:41 PDT
There is no option in Firefox 3 to change from append to replace.  The browser.tabs.loadFolderAndReplace option does not seem to work at all.  I don't mind going to about:config for this, as long as it works, but it doesn't.
Comment 16 sawickig 2008-05-20 06:53:19 PDT
There is a big discussion and argument going on resulting in making
browser.tabs.loadFolderAndReplace obsoleted !!!

I do not want to go to the core of the argument "should open in tabs" overwrite
existing open tabs or append. Both sides are valid and legitimate uses.

Make one option a default - that would make supporters of one argument happy.
Keep browser.tabs.loadFolderAndReplace working so supporters of another
argument can be happy too.

This may be silly but a lot of people are very unhappy with your arbitrary
decision to go one way and lock out everybody else who do not agree with your
choice. I am one of them and this alone may make me to stop using FF.

I cannot believe what I am writing here but in 2008 a community driven project
behaves like Stalin in 1938. Get a grip, please.
Comment 17 Quintum 2008-05-24 05:53:49 PDT
I agree. Everyday I visit lots of sites, and I open them in blocks based on folder of bookmarks. I find it correct and comfortable for the "Open all in tabs" command to overwrite existing tabs, so that when I change the bookmark block, the tabs I already opened disappear.
Comment 18 Christopher Smith 2008-05-25 09:39:51 PDT
I agree with sawickig's comment; I happen to be on the disgruntled side of the recent Pidgin textbox-resize spat.  A key to remember about Firefox is that we have the excellent option of leaving the internal config option in place and removing it from the default preferences UI; users who want to change the default can either use about:config or a simple extension.

To Quintum, while you find a destructive "open all in tabs" to be useful, your use case has the option of opening a new blank window or using "close other tabs".  With the current implementation of the tab system, the destructive "open all" is (1) surprising to at least some users, (2) not undoable, and (3) easy to hit by mistake.  Generally speaking, it's desirable to have *any* destructive change undoable, and an operation that is both easy to invoke by accident and impossible to undo should not be the default.
Comment 19 roseman 2008-06-18 09:15:44 PDT
I too agree with sawickig's comment. 
I routinely open groups of tabs while already having multiple tabs open THAT I WANT TO KEEP OPEN. 

Firefox has always been about being "customizable". 
Removing a very important user choice seems draconian. 
It is a sad day when Microsoft Internet Explorer starts to seem more customizable than Firefox. 

How soon can this very valuable asset be restored? 
A lot of us who migrated from Firefox 2.0.0.14 to 3.0 are SORRY we migrated. 
Please fix.
Comment 20 Allard Hoeve 2008-06-19 01:38:10 PDT
I'd really, really like to maintain the option. Like the earlier comments read: Firefox is about being customizable.
Comment 21 roseman 2008-06-19 08:25:39 PDT
Is this "bug" by any chance a duplicate of:  
https://bugzilla.mozilla.org/show_bug.cgi?id=395024 
(which deals with the about:cinfig entry "browser.tabs.loadFolderAndReplace")? 

Note You need to log in before you can comment on or make changes to this bug.