Closed Bug 1735048 Opened 10 months ago Closed 5 months ago

Email notifications for screen readers no longer work since Thunderbird 94.0b1

Categories

(Thunderbird :: Disability Access, defect)

Thunderbird 94
x86_64
Windows
defect

Tracking

(thunderbird_esr91 unaffected, thunderbird99 fixed, thunderbird100+ affected)

VERIFIED FIXED
100 Branch
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird99 --- fixed
thunderbird100 + affected

People

(Reporter: ali-savas, Assigned: henry)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: access, regression, regressionwindow-wanted)

Attachments

(1 file)

== Description ==
If a new email arrives, the notification was previously announced by the screen reader. This worked under Windows 10 at least for every second or third email. Under Windows 11, however, the email notifications no longer work at all.

Apparently, the "Mailbox Alert" plugin also no longer works under Windows 11.

== Steps to reproduce ==

  1. Load a screen reader like JAWS.
  2. Start Thunderbird, minimize it and wait until a new mail arrives.

=== Result ===
The screen reader will no longer announce the incoming email notification, no matter how many emails arrive. Only the sound for a new email is played.

=== Expected ===

The screen reader should announce the notification immediately when an email notification arrives.

Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1706882

Unfortunately, I cannot understand why this bug was marked as "dupplicate". In Windows 10, the notifications still worked at least halfway. In Windows 11, however, they no longer work at all. That is something completely different in my opinion.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Status: REOPENED → UNCONFIRMED
Ever confirmed: false

I found that since the update to Thunderbird 94, the notifications no longer work for screen readers. At first I assumed this had to do with the update to Windows 11, but this is not true. Under Thunderbird 93, the notification still worked at least from the second or third e-mail, but now not at all. Should I close the Bug?

OS: Windows 11 → Windows
Summary: Windows 11: Email notifications for screen readers no longer work → Email notifications for screen readers no longer work since Thunderbird 94

Actually, this may be bug 1734577 - since the notification is not shown properly maybe the screen reader doesn't want to read it either...

See Also: → 1734577

(In reply to Magnus Melin [:mkmelin] from comment #4)

Actually, this may be bug 1734577 - since the notification is not shown properly maybe the screen reader doesn't want to read it either...

May well be, however I thought until now that an event for screen readers was used here to send the messages to the screen reader. Would be interesting to see if this bug is fixed.

Did this start with 94.0b1 (released 10-06) or 94.0b2 (released 10-09)?

Flags: needinfo?(ali-savas)

(In reply to Wayne Mery (:wsmwk) from comment #6)

Did this start with 94.0b1 (released 10-06) or 94.0b2 (released 10-09)?

I'm not entirely sure, but I think it started with 94.0 B2, but as I said, I wouldn't put my hand in the fire for that.

Flags: needinfo?(ali-savas)

I could check it again, because I still had Thunderbird 94.0 B1 installed on a computer that I currently use very rarely. The problem already exists since Thunderbird version 94.0 B1.

(In reply to Magnus Melin [:mkmelin] from comment #4)

Actually, this may be bug 1734577 - since the notification is not shown properly maybe the screen reader doesn't want to read it either...

Unfortunately, the problem still exists even though bug 1734577 has been fixed. My screen reader still does not announce the notifications. So it seems that this is not the problem after all. I ask to check this again. In Thunderbird 93 at least a notification was announced from time to time.

Email notifications for screen readers are still not working unfortunately. Could someone please take a closer look at this problem? This problem has been going on for a very long time now.

I checked this again with a sighted person. For the sighted person, every email notification is visible on the screen. Only the screen reader is not notified about it.

Assuming this happened during 94.0a1 and casting a wide net, the offender should be in https://hg.mozilla.org/comm-central/pushloghtml?startdate=2021-9-10+10%3A01%3A33&enddate=2021-10-04+17%3A00%3A00 ... and Bug 1703164 is in that range - convert top level <window> to <html> throughout the Thunderbird code base

(In reply to Ali Savas from comment #9)

(In reply to Magnus Melin [:mkmelin] from comment #4)

Actually, this may be bug 1734577 (a regresion from Bug 1703164) - since the notification is not shown properly maybe the screen reader doesn't want to read it either...

Unfortunately, the problem still exists even though bug 1734577 has been fixed. My screen reader still does not announce the notifications. So it seems that this is not the problem after all. I ask to check this again. In Thunderbird 93 at least a notification was announced from time to time.

Or bug 1734577 didn't go far enough.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mkmelin+mozilla)
Keywords: access
Summary: Email notifications for screen readers no longer work since Thunderbird 94 → Email notifications for screen readers no longer work since Thunderbird 94.0b1

FWIW, notification and accessibility bug reports since August 2021 https://mzl.la/3iex2La

Samuel, do you see this problem when using nightly or beta, with Windows or linux?

Flags: needinfo?(samuel.thibault)

I don't know, but probably jp or colomban knows

Flags: needinfo?(samuel.thibault)
Flags: needinfo?(jpmengual)
Flags: needinfo?(cwendling)

Ali Savas: thank you for providing all the information so far. I have an additional question for you. Is your thunderbird set up to use system notifications for new mail alerts? Go to Settings, General, Incoming Mail; there should be a check box labelled "Use the system notification". Is this checked or un-checked?

If thunderbird is set to use system notifications then it should be sending the notifications to be handled by the Microsoft Windows desktop. Otherwise thunderbird will not use a proper system notification popup, but will instead try and fake one.

My guess is that in your case, using the system notifications should be the best option and most likely to work well with a screen reader.

If your settings were not set to use system notifications, then the other bug you opened (bug 1706882) was likely caused by a change in bug 715799, which switched to using the fake notifications by default on Microsoft Windows. This is probably effecting this bug as well, but the additional change in bug 1703164 may have made the window entirely inaccessible. However, at least testing on linux with the Orca screen reader, the fake notification was also silent in version 91.

However, if you already have the settings set to use the system notifications for new email alerts, and they are still silent but visible to a sighted person, then thunderbird somehow doesn't have access to the Microsoft Windows desktop notification system. Either the notification system is not working, or is unavailable to thunderbird specifically. I'm not sure if there are some notification permission settings in Windows that control this.

@aleca: I think you have a screen reader on Windows, can you test this with and without system notifications on 91 and daily?

Flags: needinfo?(ali-savas)
Flags: needinfo?(alessandro)

Hi Henry,

The system notifications are disabled for me. If I enable them, the notifications work, but then two sounds mix together and my Actions Center gets cluttered. In previous Thunderbird versions prior to 94.0, the notifications worked otherwise without me having to enable anything additional. The notifications are similar to when I focus a junk mail. As soon as I focus a junk mail, my Thunderbird immediately gives me the screen reader that this mail was detected as junk. It was the same with the email notifications.

Maybe you could do more with it now. Turning on the system notifications would not be a solution I like.

Flags: needinfo?(ali-savas)

(In reply to Ali Savas from comment #17)

Maybe you could do more with it now. Turning on the system notifications would not be a solution I like.

Thank you for providing the information. I understand why you might prefer not to use the system notifications, and in any case I agree that the fake notification should be made as accessible as possible, especially since it is used by default on Microsoft Windows.

My guess is that the role="alert" attribute on this line does not work on the top level. I think it may have to be moved to the <body> element.

Assignee: nobody → henry
Status: NEW → ASSIGNED
Flags: needinfo?(alessandro)
Regressed by: 1703164
Flags: needinfo?(mkmelin+mozilla)

The current patch helps make the notification readable. There's some potential double-speech when testing with JAWS, which may be configuration dependent. But I'll still close this bug with the current patch, and everything else will be addressed in bug 1706882.

Blocks: 1706882

As far as I know this is a problem of JAWS in interaction with Mozilla applications. The same problem also exists with Firefox. However, the messages were also spoken twice before.

From which beta version can I test the patch?

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/2f4217ac31ff
Move role="alert" from toplevel to body for newmailalert.xhtml. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 10 months ago5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch

(In reply to Ali Savas from comment #21)

From which beta version can I test the patch?

99.0b2 tuesday or so next week, if we uplift this patch before we build it.

Comment on attachment 9268026 [details]
Bug 1735048 - Move role="alert" from toplevel to body for newmailalert.xhtml. r=aleca

[Approval Request Comment]
Regression caused by (bug #): bug 1703164
User impact if declined: Email notifications are not spoken by screen readers.
Testing completed (on c-c, etc.): Tested on JAWS on windows, where notifications were known to be spoken before the regression.
Risk to taking this patch (and alternatives if risky): Low. This just adds the correct "role" attribute to a body element.

Attachment #9268026 - Flags: approval-comm-beta?

Comment on attachment 9268026 [details]
Bug 1735048 - Move role="alert" from toplevel to body for newmailalert.xhtml. r=aleca

[Triage Comment]
Approved for beta

Attachment #9268026 - Flags: approval-comm-beta? → approval-comm-beta+

The bug seems to have been fixed. Anyway, it works for me again.

Status: RESOLVED → VERIFIED

Many thanks for taking care of this Henry!

Flags: needinfo?(jpmengual)
Flags: needinfo?(cwendling)
You need to log in before you can comment on or make changes to this bug.