xpinstall/packager cannot package Mozilla Firebird

VERIFIED DUPLICATE of bug 216137

Status

()

Firefox
Build Config
VERIFIED DUPLICATE of bug 216137
15 years ago
14 years ago

People

(Reporter: lidl, Assigned: Brian Ryner (not reading))

Tracking

unspecified
Firefox1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I finally got a tip-of-the-cvs tree from last night to build into a
phoenix binary.  It runs OK from my build tree, but I'd like to be
able to package up a phoenix distribution for myself to use on my
primary desktop machine, as well as give away copies to some friends
that wanted to play with it.

I realize it's way early in the product cycle for phoenix, but this
would make it easier to distribute binaries...

After a successful build, I attempted to package it like I do for mozilla releases:

lidl@hostname-56: pwd
/data/obj/mozilla/xpinstall/packager
lidl@hostname-57: gmake
gmake: *** No rule to make target `../../dist/bin/mozilla-bin', needed by
`mozilla-i386-pc-bsdi4.3.tar.gz'.  Stop.

Can phoenix support be added to the packager Makefile?

Comment 1

15 years ago
Confirming. As a stopgap measure, going through xpinstall/packager/Makefile and
replacing instances of "mozilla" with "phoenix" (except in variable names) works
for me.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: BSDI → All

Updated

15 years ago
Blocks: 182409

Comment 2

15 years ago
Workaround (quick&dirty) from my nightly build script for Solaris:
-- snip --
% cd xpinstall/packager/
% gmake MOZ_PKG_APPNAME=phoenix MOZILLA_BIN=../../dist/bin/phoenix-bin
-- snip --

Updated

15 years ago
Summary: xpinstall/packager cannot package phoenix → xpinstall/packager cannot package Mozilla Firebird

Updated

14 years ago
Target Milestone: --- → Firebird1.0

Comment 3

14 years ago
-> All/All

The problem is escalated on OS X where the there's you also hit the logic that
defines _APPNAME
Hardware: PC → All

Updated

14 years ago
QA Contact: asa

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 216137 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.