Closed Bug 1737730 Opened 1 year ago Closed 11 months ago

Re-enable printing multiple messages at the same time

Categories

(Thunderbird :: General, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91 verified, thunderbird94 wontfix)

VERIFIED FIXED
95 Branch
Tracking Status
thunderbird_esr91 --- verified
thunderbird94 --- wontfix

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Regression, )

Details

(Keywords: regression)

Attachments

(2 files)

I made a fix for this after all. It's not the world's greatest fix but it does work, and that is better than the current situation.

See Also: → 1727107
Duplicate of this bug: 1727865

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/e66077010600
Enable printing of multiple messages. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Duplicate of this bug: 1738035

(In reply to Geoff Lankow (:darktrojan) from comment #0)

I made a fix for this after all. It's not the world's greatest fix but it does work, and that is better than the current situation.

THANK YOU. THANK YOU. THANK YOU!

Duplicate of this bug: 1738844

Tested this using the 95.0b1 release candidate on Windows 10.
It appears it calls the system dialog bypassing a preview phase, but worked.

Duplicate of this bug: 1739059

Am I understanding that the next update will have multiple email printing enabled again? Oh please say it's so! And how long will it be before the next update comes to us? My boss is having conniptions!

Yes, probably uplifted to 91 within a few weeks.

This doesn't print the list of attachments. Trying to debug this, we noticed that a debug build crashes here:
https://searchfox.org/mozilla-central/rev/df6434d2ebfdf2b5f89f205fc81d60d64a774fe1/toolkit/components/windowwatcher/nsWindowWatcher.cpp#1039

Looks like the patch here also enables printing when the preview is switched off:
https://hg.mozilla.org/comm-central/rev/e66077010600#l3.69
In that case the attachment list is also not printed.

That is really weird, but you're right. Please open a new bug.

Your QA department should take care of the necessary follow-up.

Regressions: 1741282
Duplicate of this bug: 1741321
Duplicate of this bug: 1741622
Duplicate of this bug: 1742627

Comment on attachment 9247672 [details]
Bug 1737730 - Enable printing of multiple messages. r=mkmelin

Let's get this in ESR, with or without bug 1741282. Preferably with.

[Approval Request Comment]
Regression caused by (bug #): bug 1711822
User impact if declined: can't print multiple messages or with the preview pane closed
Testing completed (on c-c, etc.): in 95 since 95 was Daily
Risk to taking this patch (and alternatives if risky): low

Attachment #9247672 - Flags: approval-comm-esr91?

Comment on attachment 9247672 [details]
Bug 1737730 - Enable printing of multiple messages. r=mkmelin

[Triage Comment]
Approved for esr91

Attachment #9247672 - Flags: approval-comm-esr91? → approval-comm-esr91+

Testing the 91.4.0 release candidate on Windows 10 21H2.

The first email came out with the font so tiny it is impossible to read. The second was better.

Selecting the first email only, the text showed small in the preview, so I switched from "Fit to page width" to Scale 100, canceled that print job, selected two emails, printed the first page of each, and they look alike. The first one can now be read.

Verified in testing 91.4.0 and 95.0b5 on Windows 10 and Fedora 35 Workstation Linux.

Status: RESOLVED → VERIFIED

How much longer before this is fixed in an update? We really depended on printing multiple messages, and we have a big online event coming up that will bring in hundreds of email messages per hour for a day or so. We really need this! thanks...

It is fixed in 91.4.0 which was rolled out earlier this week.

(In reply to Mary Bolack from comment #24)

How much longer before this is fixed in an update? We really depended on printing multiple messages, and we have a big online event coming up that will bring in hundreds of email messages per hour for a day or so. We really need this! thanks...

Hi Mary, as Magnus said, this is fixed in the latest release version of Thunderbird, so you just need to update to that. I have tested this for you and it works for me on Windows 10, TB 91.4.0 (see screenshot). Please follow the following steps:

  • Verify that you're using TB 91.4.0:
    • ≡ > Help > About Thunderbird - that should show an update button to click on if you're not updated.
    • If it shows a version below TB 91.4.0 without showing an update button, please download the latest Version from TB homepage and just install in the same program folder as your existing installation. There is no need to uninstall the old version first, and your data will remain intact. Note that if you install into a different folder, it will create a new profile (but your old profile will still exist), so that would give you a tabula rasa setup.
  • Select multiple messages
  • Ctrl+P -> shows system print dialog
  • choose your favorite printer from system print dialog, then click Print button

Please share with us if it works for you after the above procedure.
If you're still facing challenges, please comment here on this bug with your OS and TB language details, and needinfo my email: below your comment here, check [x] Request information from: other: :thomas8 then choose my email and submit.

Flags: needinfo?(mbolack)

Additional remark: If you're using a virtual printer, like "Microsoft print to PDF", you may still be prompted to enter a file name for each printed message. That is because TB still spools all the messages individually. We've heard that "PDFCreator" (no advertising intended) can merge multiple jobs into one PDF. I'm pretty sure other products can do that, too.

(In reply to Thomas D. (:thomas8) from comment #26)

Created attachment 9254941 [details]
Screenshot: Verify TB Version 91.4, printing multiple messages (success)

(In reply to Mary Bolack from comment #24)

How much longer before this is fixed in an update? We really depended on printing multiple messages, and we have a big online event coming up that will bring in hundreds of email messages per hour for a day or so. We really need this! thanks...

Hi Mary, as Magnus said, this is fixed in the latest release version of Thunderbird, so you just need to update to that. I have tested this for you and it works for me on Windows 10, TB 91.4.0 (see screenshot). Please follow the following steps:

  • Verify that you're using TB 91.4.0:
    • ≡ > Help > About Thunderbird - that should show an update button to click on if you're not updated.
    • If it shows a version below TB 91.4.0 without showing an update button, please download the latest Version from TB homepage and just install in the same program folder as your existing installation. There is no need to uninstall the old version first, and your data will remain intact. Note that if you install into a different folder, it will create a new profile (but your old profile will still exist), so that would give you a tabula rasa setup.
  • Select multiple messages
  • Ctrl+P -> shows system print dialog
  • choose your favorite printer from system print dialog, then click Print button

Please share with us if it works for you after the above procedure.
If you're still facing challenges, please comment here on this bug with your OS and TB language details, and needinfo my email: below your comment here, check [x] Request information from: other: :thomas8 then choose my email and submit.

Yes, it is working! Yippee! I had to manually update, which is unusual, because I have auto updates turned on. But who cares? It's working! Thank you all!

Flags: needinfo?(mbolack)

.

Depends on: 1711408
Keywords: regression
Regressed by: 1727107
Summary: Enable printing multiple messages at the same time → Re-enable printing multiple messages at the same time
You need to log in before you can comment on or make changes to this bug.