Open Bug 1737767 Opened 1 month ago Updated 29 days ago

Unread messages not bold font on MacOS 12.0.1 (Monterey)

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 94
defect

Tracking

(Not tracked)

UNCONFIRMED

People

(Reporter: dany.rispoli, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.81 Safari/537.36

Steps to reproduce:

I upgraded to latest MacOS 12.0.1 (Monterey) and installed latest Thunderbird Beta (94.0b4).

Actual results:

In the left sidebar (Folder list), folders with unread messages does not have bold font. In the messages list same issue, the unread messages are not bold so is impossible to view which messages are unread.

Expected results:

The folder name that contains unread message must have a bold font like previous behavior.
The messages in unread status must have a bold font.

According to bug 1715898 comment 5 this problem exists only on non English systems. I changed my System Primary Language to English and it works. Then I changed it back to my language this Problem occurs again.

I confirm the Jürgen Lueger comment: changing my MacOs primary language to English Thunderbird works good and fonts are rendered correctly.
Returning to my language (Italian) problems occurs again.

NOTE: after set primary language to English, MacOS ask me to reboot the system to apply new language. If you not reboot the system, MacOS interface does not change language but Thunderbird works.

Issue confirmed. Changing from Catalan language to English, Thunderbird 91.2.1 shows the unread emails in bold again.

I'm using Version 78.14.0 (64-Bit) of TB and it's the same phenomenon. (Haven't checked changing the system's primary language yet).
So the solution will hopefully come with a newer version of TB, like the last time it happened? It strikes me odd, why it happens in the first place.

I can confirm the problem on a German macOS 12.0.1 for both Thunderbird 91.2.1 and Firefox 93.

It seems that both Applications are not able to access the system font "SF Pro" and use "Helvetica" instead which is much narrower and seems not to have a bold variant.

I tried to install the downloadable version of SF Pro from Apple but that didn't help.

Switching the system language to English helps.

Duplicate of this bug: 1738254

Looks like the solution will come via bug 1732629 - which is approved for Firefox 91.3 esr, so it should be in Thunderbird 91.3.0 next week. But didn't make it in time for our 94.0b5 beta. It will be in our beta 95.

Depends on: 1732629
Duplicate of this bug: 1738280
Duplicate of this bug: 1737791

Same here, on a German system running TB 78.14.0

TB 91.3.0 (64-Bit) works well now - without userChrome.css adaptation!

You need to log in before you can comment on or make changes to this bug.