Closed Bug 1739090 Opened 11 months ago Closed 11 months ago

Header 'To' is useless in the newsgroups section

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 96
defect

Tracking

(thunderbird_esr91 unaffected)

RESOLVED FIXED
96 Branch
Tracking Status
thunderbird_esr91 --- unaffected

People

(Reporter: toscha, Assigned: aleca)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:96.0) Gecko/20100101 Firefox/96.0

Steps to reproduce:

While reading newsgroups the header 'To' is displayed with no value. This started with Daily 96.0a1. 'To' is simply not a useful header in newsgroups section at all. It just should not be displayed.

Probably a regression from bug 1556261.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(alessandro)
Keywords: regression
Regressed by: 1556261

On RSS feeds the To line is also needlessly visible.

'To' is simply not a useful header in newsgroups section at all.

That's not quite true, though it certainly shouldn't be shown when it's empty. For example, Gmane (converts mailing lists to newsgroups) messages typically contain both a Newgroups and To header.

Assignee: nobody → alessandro
Flags: needinfo?(alessandro)

Silly mistake due to the CSS overriding the hidden attribute of the field container.

Status: NEW → ASSIGNED

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/e2daab3a63e4
Do not override the [hidden] attribute of the To field with the CSS display property. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch
You need to log in before you can comment on or make changes to this bug.