Open Bug 1745571 Opened 8 months ago Updated 1 day ago

Counter for the total number of contacts in an address book missing for new address book implementation

Categories

(Thunderbird :: Address Book, defect, P2)

Thunderbird 96

Tracking

(thunderbird_esr102+ affected, thunderbird102 affected, thunderbird104 affected)

REOPENED
105 Branch
Tracking Status
thunderbird_esr102 + affected
thunderbird102 --- affected
thunderbird104 --- affected

People

(Reporter: chriechers, Assigned: nicolai)

References

(Blocks 1 open bug)

Details

(Keywords: regression, ux-efficiency)

Attachments

(1 file)

The old address book had a 'Total contacts in <address book>' counter in the status bar of the Address Book window. Such a counter is useful for a number of reasons.
The new address book implementation is lacking such a counter.
Please add a counter for the no. of contacts in an address book for the new address book implementation.

Yes, and another counter for selected contacts, please!

Type: enhancement → defect
Keywords: regression
Summary: counter for the no. of contacts in an address book missing for new address book implementation → Counter for the total and selected number of contacts in an address book missing for new address book implementation

Is this a lost cause for v102.0?

Unfortunately, the status bar currently is devoted to the main message pane.

Severity: -- → S4

I'm seeing questions in Support Forum about where is the total number of contacts they have for mailing lists and address books.

This used to be displayed in the Status Bar.
But if not possible under new design - as an alternative - could it be added to the right of the actual address book/mailing list name - similar to how the Folder Pane has the folder pane columns option to display number of emails in folder ?

Alex can you assign priority etc?
I also miss this fwiw

Flags: needinfo?(alessandro)

We weren't able to add new strings for this in 102 as we missed that window.
We still have the old string here: https://searchfox.org/comm-central/rev/ded3b63d927ab68e9ae12d11eddb9929e7527d38/mail/locales/en-US/chrome/messenger/addressbook/addressBook.properties#99

We can temporarily use this old string to show an indicator at the bottom of the Address Book list (first column) only for 102, and then move things forward for post-102 with new strings.

Nicolai, would be able to take care of this?
Also CC'ing Geoff to make him aware of this temporary fix.

Assignee: nobody → nicolai
Flags: needinfo?(alessandro)
Keywords: ux-efficiency
Priority: -- → P2
Status: NEW → ASSIGNED

The counter for selected contacts was never part of 91, that's an extra feature that we have ready but didn't land because of string freeze.
RFE and regressions shouldn't be listed together in the same bug.

Summary: Counter for the total and selected number of contacts in an address book missing for new address book implementation → Counter for the total number of contacts in an address book missing for new address book implementation
Target Milestone: --- → 105 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/2c97012ce4e1
Add total count for a selected address book. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 2 days ago
Resolution: --- → FIXED

Reopen this ticket, the count is not updated on contact creation or deletion.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
You need to log in before you can comment on or make changes to this bug.