Closed Bug 1747804 Opened 11 months ago Closed 11 months ago

HAR file export still results in an empty file

Categories

(DevTools :: Netmonitor, defect)

defect

Tracking

(firefox97 fixed)

RESOLVED FIXED
97 Branch
Tracking Status
firefox97 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

Details

Attachments

(1 file)

Bug 1740116's comment 0 still reproduces, but may now require two subsequent reload of the test page to reproduce consistantly.

I did not realized but bug 1740116's patch only fixed one issue specific to cancelled request.
It looks like we also fail generating HAR reports because of iframes being removed.
When removing an iframe, we destroy the related iframe's NetworkEventActors and so can't fetch the related requests lazy data.

We should probably make HAR codebase more resilient to error and start with ignoring individual requests that we are unable to fetch. So that we at least generate the HAR report for everything else.

We may also consider automatically enabling persist when doing HAR record? Or display some warning when retrieving HAR data while persist is disabled.

Depends on: 1747805

HAR export was still producing empty har files if any of the request
currently displayed in the netmonitor can't be completely retrieved.
This includes all lazy data. But if any request has been destroyed in the server
fetching any lazy data will throw.

Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0b10ddd0ec17
[devtools] Fix har export when some requests can't be retrieved. r=nchevobbe
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 97 Branch
You need to log in before you can comment on or make changes to this bug.