Closed Bug 1755920 Opened 2 years ago Closed 2 years ago

[US][lowes.com] The autofill dropdown is not triggered and the autofill functionality is not working for multiple fields

Categories

(Toolkit :: Form Autofill, defect, P3)

Desktop
All
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox97 --- affected
firefox98 --- affected
firefox99 --- affected

People

(Reporter: ailea, Unassigned)

References

(Blocks 2 open bugs, )

Details

Attachments

(2 files)

Attached video lowes.mp4

Affected Versions:

Nightly 99.a1, Beta 98 and Release 97

Tested on:

MacOS 11
Windows 10

Preconditions:

browser.search.region US
extensions.formautofill.addresses.enabled - true
extensions.formautofill.addresses.supported to "detect"
extensions.formautofill.addresses.supportedCountries US,CA
download latest Firefox Nightly with region locale
have a complete address already saved in about:preferences#privacy

Steps to reproduce:

  1. Reach the address form on lowes.com
  2. Click in any name or address fields and using the autofill feature, select 1 saved address entry.
  3. Click in the Company field
  4. Click in the City field
  5. Click in the Zip Code field

Expected Results:

  1. The address autofill dropdown should be displayed for all fields.
  2. All the fields should be successfully auto-filled.
  3. The State dropdown should be correctly auto-filled.

Actual Results:

  1. The address autofill dropdown is not displayed for City, Zip and Company fields.
  2. The City, Zip and Company are not auto-filled.
  3. The State dropdown is not auto-filled.

Notes:

autocomplete attribute is set to "off" (see comment 1).
Reproducible on Chrome: Yes, in Chrome the Zip and City fields are working but the other ones are not.

Please let me know if separate bugs are needed for the issues described above.

Attached image lowes.png
Blocks: 1754879
Priority: -- → P3

Closing as resolved: Worksforme since the issue isn't reproducible anymore.
Tested on Windows 10 x64, macOS 11.6 using the latest Nightly 104.0a1, Beta 103.0b2 and Firefox 102.0.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: