HTTP Refresh (change columns in bugzilla)




19 years ago
18 years ago


(Reporter: Warren Harris, Assigned: ruslan)


Dependency tree / graph

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [nsbeta2+], URL)


(2 attachments)



19 years ago
I did a bugzilla query, got the list of results and tried the Change Columns
link at the bottom of the page. The took me to the change columns page, but when
I submitted my change, I didn't get a list of results.

Comment 1

19 years ago
Reassigning to Eric.


19 years ago
Whiteboard: [PDT+]

Comment 2

19 years ago
Putting on PDT+...but I think this is a form submission dup.


19 years ago
Whiteboard: [PDT+] → [PDT+] week of 19-Nov-1999

Comment 3

19 years ago
This is the http headers of the response we get back from colchange.cgi:

HTTP/1.1 200 OK
Date: Tue, 16 Nov 1999 23:28:52 GMT
Server: Apache/1.3.4 (Unix)
Refresh: 0; URL=buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=RE...
Set-Cookie: COLUMNLIST=changeddate severity priority platform owner status r...
Connection: close
Content-Type: text/html

The Refresh header seems to be getting ignored.  Is Refresh implemented yet?
I'll cook up a simplified test case.
OS: Windows NT → All
Hardware: PC → All

Comment 4

19 years ago
Very simple test case works ok, still working on this...


19 years ago
Assignee: pollmann → gagan
Component: Form Submission → Necko

Comment 5

19 years ago
Opps, I tested the very simple case in Nav, so of course it worked.  :)

This is my failing simple test case:


print "Refresh: 0; URL=
Content-Type: text/html

  Forwarding you to

Accesible from http://blueviper/bugs/refresh.cgi


19 years ago
Summary: [DOGFOOD] can't change columns in bugzilla → [DOGFOOD] HTTP Refresh not implmented

Comment 6

19 years ago
Changing Summary:

can't change columns in bugzilla -> HTTP Refresh not implemented


19 years ago
Assignee: gagan → valeski

Comment 7

19 years ago
The refresh header is just another header as far as HTTP in Necko is concerned.
Its really the client's responsibility to parse and interpret it.
Jud if I remember the plan was to have a common place to trigger the refresh.
(common for both HTTP headers and META HTTP-EQUIV or REFRESH in HTML) In my
perspective the correct way to implement this would be to let the client of
Necko (webshell) watch the OnHeadersAvailable and if a refresh is found trigger
exactly the same behaviour as the HTML equivalent of it. Since I am going to be
gone for the next few weeks, am assigning this to you (but this should probably
just be webshell) Plus you always wanted a free car wash... didn't ya?

Comment 8

19 years ago
note: the date in the whiteboard as put in by someone else prior to my having
this bug. I've got other PDT+ bugs that are taking precedence over this right
now. I don't have an ETA. This is definately webshell/docloader level
functionality. We decided that this stuff would stay out of necko. because I did
the meta refresh stuff I'm probably the right person for this.


19 years ago
Whiteboard: [PDT+] week of 19-Nov-1999 → [PDT+] 12/3


19 years ago
Whiteboard: [PDT+] 12/3 → [PDT-] 12/3

Comment 9

19 years ago
Marking PDT-; we can leave without refresh for now.

Comment 10

19 years ago
eric, can you please repost the test URL?

Comment 11

19 years ago
Hm...  Let this serve as my reminder to avoid unix commands involving the
character *

It's up now!

Comment 12

19 years ago
Is this bug related to bug 16161?

Comment 13

19 years ago
*** Bug 16161 has been marked as a duplicate of this bug. ***

Comment 14

19 years ago
I've taken an interest in this bug.  If anybody decides to work on it you may
want to check with me ( to see what I've learned.  Or ideally,
I'll have it fixed before anybody else decides to work on this.

Comment 15

19 years ago
I have a fix I'm testing in my local tree. The date in the status whiteboard
field indicates that I should have it checked in by Friday.

Comment 16

19 years ago
I've made the webshell (the implementor of nsIRefresh and the one who handles
META HTTP-EQUIV refresh) an observer of HTTP response headers. When it finds a
refresh header it applies the same logic/code that does the HTTP-EQUIV
refreshing. I haven't had a chance to thouroughly test/optimize it. I'll attach
the diffs.

Comment 17

19 years ago
Created attachment 3080 [details] [diff] [review]
proposed patch for mozilla/webshell/src/nsWebShell.cpp

Comment 18

19 years ago
Created attachment 3081 [details] [diff] [review]
updated patch


19 years ago
Target Milestone: M12

Comment 19

19 years ago
updating milestone


19 years ago
Depends on: 13374


19 years ago
Assignee: valeski → travis

Comment 20

19 years ago
assigning to travis as this is being redone in the webshell redesign.

Comment 21

19 years ago
*** Bug 21001 has been marked as a duplicate of this bug. ***


19 years ago
Target Milestone: M12 → M13

Comment 22

19 years ago
Moving to M13 since this has been determined to be PDT-.

(Travis, you can still fix this for M12 but it's not a requirement.)

Comment 23

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking



19 years ago
Priority: P3 → P2
Summary: [DOGFOOD] HTTP Refresh not implmented → [FEATURE] HTTP Refresh not implmented
Whiteboard: [PDT-] 12/3
Target Milestone: M13 → M14

Comment 24

19 years ago
Replaced "DOGFOOD" with "FEATURE" in summary.  Moved to M14.


19 years ago
Summary: [FEATURE] HTTP Refresh not implmented → [FEATURE] HTTP Refresh

Comment 25

19 years ago

Comment 26

19 years ago
*** Bug 22148 has been marked as a duplicate of this bug. ***


18 years ago
Blocks: 24739

Comment 27

18 years ago
*** Bug 24678 has been marked as a duplicate of this bug. ***

Comment 28

18 years ago
Putting on beta1 and PDT+ radar since 24678 was to be marked that today.
Keywords: beta1
Whiteboard: [PDT+]
Adding bugzilla change columns to summary to forestall future duplicates when 
people query for that common problem in the open bugs.
Summary: [FEATURE] HTTP Refresh → [FEATURE] HTTP Refresh (change columns in bugzilla)


18 years ago
Whiteboard: [PDT+] → [PDT+] UNKNOWN

Comment 30

18 years ago
Need an ETA for fix date in Status Whiteboard ASAP please.

Comment 31

18 years ago
removing PDT+ designation, switching to beta2 keyword
Keywords: beta1 → beta2
Whiteboard: [PDT+] UNKNOWN

Comment 32

18 years ago
Moving from M14 to M15.  M14 is out already.  Please change to even later 
milestone if needed
Target Milestone: M14 → M15

Comment 33

18 years ago
Guessing at correct QA contact...
QA Contact: cpratt → sairuh
QA Contact: sairuh → tever

Comment 35

18 years ago
Move to M16 for now ...
Target Milestone: M15 → M16


18 years ago
Keywords: nsbeta2

Comment 36

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. Moving over to ruslan per valeski.
Assignee: travis → ruslan
Whiteboard: [nsbeta2+]

Comment 37

18 years ago

there's nothing to do here as far as necko is concerned. Has somebody fixed 
webshell to make it work properly?
*SPAM* - adding mostfreq keyword to bugs with loads of DUPEs. Please aid this 
effort by adding this keyword to any bugs with more than 15 DUPEs.

Keywords: mostfreq

Comment 39

18 years ago
Ok. Unfortunately this can't be done via Jud's original patch cuz DocShell would 
not have the url set at the point when the interceptor would be called. Anyway. 
I've a different patch which works. Awaiting approval to check in.
Summary: [FEATURE] HTTP Refresh (change columns in bugzilla) → HTTP Refresh (change columns in bugzilla)

Comment 40

18 years ago
checked in
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 41

18 years ago
re-opening this.

Test case works but something is still not working with bugzilla's refresh.  The 
columns do not change when submit is pressed.  They do change when you enter the 
query page for a second time.

trace+ output below 

HTTP/1.1 200 OK
Date: Wed, 31 May 2000 23:36:58 GMT
Server: Apache/1.3.12 (Unix)
Refresh: 0; URL=buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPEN
Set-Cookie: COLUMNLIST=severity priority platform status resolution target_miles
tone qa_contact status_whiteboard keywords summary ; path=/ ; expires=Sun, 30-Ju
n-2029 00:00:00 GMT
Set-Cookie: SPLITHEADER=0 ; path=/ ; expires=Sun, 30-Jun-2029 00:00:00 GMT
Keep-Alive: timeout=15, max=98
Connection: Keep-Alive
Transfer-Encoding: chunked
Resolution: FIXED → ---

Comment 42

18 years ago
The current theory is that Cookies sent as part of the response containing 
Refresh header are not be processed by the browser till later for some reason. 
Tom is verifing. We need to close this bug and open up another bug for cookies.

Comment 43

18 years ago
marking fixed 
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 44

18 years ago
NT 2000060108

Refresh is working.   Problem with bugzilla appears to be related to cache.  
Opening new bug.
You need to log in before you can comment on or make changes to this bug.