Closed Bug 1758015 Opened 5 months ago Closed 5 months ago

Scrollbar is visible in YouTube fullscreen mode

Categories

(Web Compatibility :: Desktop, defect)

defect

Tracking

(firefox-esr91 unaffected, firefox97 unaffected, firefox98 unaffected, firefox99 affected)

RESOLVED INVALID
Tracking Status
firefox-esr91 --- unaffected
firefox97 --- unaffected
firefox98 --- unaffected
firefox99 --- affected

People

(Reporter: saschanaz, Unassigned)

References

(Regression)

Details

(Keywords: regression)

YouTube hides the scrollbar in fullscreen mode but it's now visible whenever moving mouse or scrolling the page.

Turning on "Always show scrollbars" Windows option and reloading the page fixes it. (Without reloading it still shows the scrollbar.)

Flags: needinfo?(emilio)

Strictly speaking I don't think it's that patch that regresses this, but mozregression blames it anyway for a reason, so 😉

Set release status flags based on info from the regressing bug 1757647

This happens on other platforms with overlay scrollbars as well, and AFAICT is working as intended, as the page is scrollable. See also https://bugs.chromium.org/p/chromium/issues/detail?id=1290227 which is the equivalent Chromium issue (also WONTFIXed).

If YouTube wanted to hide the overlay scrollbars they could use scrollbar-color: transparent transparent;. Maybe we should contact with that suggestion them if you feel strongly about that? We have a mailing list with them IIRC.

Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(emilio)
Resolution: --- → INVALID

(I think it's more like WONTFIX than INVALID)

If the cursor is at the right corner the scrollbar never disappears, and that's a significant behavior change which will disturb users. Probably worth pinging them, but I don't think I know anything about scrollbars. I can start a thread and then maybe you could add more info. Does that sound good?

BTW, does this also happen on macOS?

(In reply to Kagami :saschanaz from comment #4)

(I think it's more like WONTFIX than INVALID)

If the cursor is at the right corner the scrollbar never disappears, and that's a significant behavior change which will disturb users. Probably worth pinging them, but I don't think I know anything about scrollbars. I can start a thread and then maybe you could add more info. Does that sound good?

Sure, sounds good :)

(In reply to Kagami :saschanaz from comment #5)

BTW, does this also happen on macOS?

Yes.

See also https://bugs.chromium.org/p/chromium/issues/detail?id=1290227 which is the equivalent Chromium issue (also WONTFIXed).

I can't confirm this happens on Edge Dev, that flag doesn't give me the overlay scrollbar at all 🤔. Can you? I'd like to say "this affects both Edge and Firefox, we need to fix it".

I can probably confirm tomorrow. But anyways just pointing to the Chromium bug should be enough.

Hah, never mind. I just got the Canary build and I can confirm that it's still an issue there.

Has Regression Range: --- → yes
Duplicate of this bug: 1763847

Let me try to reach out to YouTube.

Flags: needinfo?(emilio)
Component: Widget: Win32 → Desktop
Product: Core → Web Compatibility

Ah, sorry, Kagami already did, this is filed internally at Google as b/224524055, for future reference.

Flags: needinfo?(emilio)
Duplicate of this bug: 1770541
You need to log in before you can comment on or make changes to this bug.