Closed Bug 1759372 Opened 5 months ago Closed 5 months ago

Status Bar: "Get Messages" Function - no pop activity shown in the status bar in 99.0b1

Categories

(MailNews Core :: Networking: POP, defect)

Thunderbird 99
defect

Tracking

(thunderbird_esr91 unaffected, thunderbird99 fixed)

RESOLVED FIXED
100 Branch
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird99 --- fixed

People

(Reporter: edinger, Assigned: rnons)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:98.0) Gecko/20100101 Firefox/98.0

Steps to reproduce:

Clicked on the Menu bar's "Get Mail" option to request new email from the server.

User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:99.0) Gecko/20100101
Thunderbird/99.0

Actual results:

Though there was no indication in the status bar that the function was initiated, the mail retrieval function did seem to be working.

Expected results:

Expected a status bar message indicating that mail was being requested from the server.

Summary: Status Bar: "Get Messages" Function - no activity shown in the status bar in 99.0b1 (Mozilla/5.0 - Windows NT 10.0; Win64; x64; rv:99.0) Gecko/20100101 Thunderbird/99.0 → Status Bar: "Get Messages" Function - no activity shown in the status bar in 99.0b1
Assignee: nobody → remotenonsense
Status: UNCONFIRMED → ASSIGNED
Component: Untriaged → Networking: POP
Ever confirmed: true
Product: Thunderbird → MailNews Core
Regressed by: pop3-js
Summary: Status Bar: "Get Messages" Function - no activity shown in the status bar in 99.0b1 → Status Bar: "Get Messages" Function - no pop activity shown in the status bar in 99.0b1
Target Milestone: --- → 100 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/ad1eb74d45cc
Show POP3 activity message in status bar. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

Comment on attachment 9267806 [details]
Bug 1759372 - Show POP3 activity message in status bar. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1707548
User impact if declined: POP3 activity not shown in status bar.
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9267806 - Flags: approval-comm-beta?
Duplicate of this bug: 1760196
Duplicate of this bug: 1760307
Duplicate of this bug: 1760425

Not only is no activity shown, no messages are retrieved. Same for F5 and Shift F5 shortcut. Only reliable way to retrieve messages is shut down and reopen TB.

(In reply to doug2 from comment #7)

Not only is no activity shown, no messages are retrieved. Same for F5 and Shift F5 shortcut. Only reliable way to retrieve messages is shut down and reopen TB.

Yes, I can confirm also.

Comment on attachment 9267806 [details]
Bug 1759372 - Show POP3 activity message in status bar. r=mkmelin

[Triage Comment]
Approved for beta

Attachment #9267806 - Flags: approval-comm-beta? → approval-comm-beta+

(In reply to doug2 from comment #7)

Not only is no activity shown, no messages are retrieved. Same for F5 and Shift F5 shortcut. Only reliable way to retrieve messages is shut down and reopen TB.

Can you file a new bug report? Set mailnews.pop3.loglevel to All to get some debug logs, thanks.

(In reply to Ernestas Gruodis from comment #8)

(In reply to doug2 from comment #7)

Not only is no activity shown, no messages are retrieved. Same for F5 and Shift F5 shortcut. Only reliable way to retrieve messages is shut down and reopen TB.

Yes, I can confirm also.

Well, I just sent a test message from my Google account to my Comcast POP3 account using 99.0b1 on Fedora Linux.
Selected the account in the Folder pane.
Clicked Get Messages.
Got the test message with no activity being shown in the Status bar.
Now I'm getting tons of duplicate messages I had already received.
Probably because they are not marked as read on the server.

As of this AM, Win 11 64 bit TB 99.0b1 Had a dozen mail items waiting, read them, checked TB status, 99.0b2 available, installed and restarted. Requested mail (one account), received additional mail items correctly. Requested mail for another account, progress displayed correctly. Looks like it is all working. Thanks!

Spoke too soon. Repeated attempts to get new mail from main Gmail account show no activity. Other account show "<account name>: no new mail." Main account shows nothing. Any previous status in the field is not replaced.

I haven't updated to 99.0b2 on Linux as yet, but upon opening 99.0b1 this morning, my Comcast POP3 account downloaded a bunch of old mails after I marked them all read on the web interface for the account.

Now I have duplicates and triplicates.

I guess I'll go to the web interface and delete them all.

Working fine here on 99.0b2 (Win 10 64bit) on both POP accounts (including one gmail one). But I never had an issue with actually getting the messages, just the lack of status info.

continuing to test: Changed account status of automatically download new messages to no. Retested, same as comment 14. Shut down TB and restarted - new mail arrives. Check download new mail - see all accounts responding with progress and status. Changed automatically download new mail to yes. Working ok. Not consistent.

(In reply to doug2 from comment #17)

continuing to test: Changed account status of automatically download new messages to no. Retested, same as comment 14. Shut down TB and restarted - new mail arrives. Check download new mail - see all accounts responding with progress and status. Changed automatically download new mail to yes. Working ok. Not consistent.

You don't consistently see activity in the Status bar?

Despite the other issues which probably are other bugs, I consistently see activity in the status bar when using Get Messages, or the keyboard shortcuts for my POP3 account using 99.0b2 on Fedora 35 Linux.

Still need to test on Windows 10.

No, I don't consistently see activity in the Status bar. If I request new mail to my main account, I see no status change. If I request new mail to a secondary account, I see Status change. Mail is being downloaded on my schedule to all accounts - which was not happening consistently in 99.0b1.
Right now, I'm seeing a "Deleted 3 messages from Drafts" status, which is really weird! I should only see "Deleted ... from Trash." I "repaired" the Drafts folder (no change in content) and got a status of Done, then requested mail and there was no status change.

I got another status "Deleted x messages from Drafts." I only have 2 drafts folders (one empty) and neither one changed.

No incoming mail. Shut down TB & restarted. Received 10 new emails.

(In reply to Ping Chen (:rnons) from comment #11)

(In reply to doug2 from comment #7)

Not only is no activity shown, no messages are retrieved. Same for F5 and Shift F5 shortcut. Only reliable way to retrieve messages is shut down and reopen TB.

Can you file a new bug report? Set mailnews.pop3.loglevel to All to get some debug logs, thanks.

Hi, it's really helpful if you can provide some debug logs.

(In reply to WaltS48 [:walts48] from comment #12)

Now I'm getting tons of duplicate messages I had already received.
Probably because they are not marked as read on the server.

We have a popstate.dat in every pop3 message folder (e.g. ProfD/Mail/pop3.hostname/popstate.dat), every pop message is represented by a unique UIDL string. If a UIDL is found in popstate.dat, it won't be fetched again. So seems the first time you fetched messages, popstate.dat was not updated correctly. Please file a new bug with some logs, thanks.

Need logging help. Looking up mailnews says TB 99+ does not use this type of logging?? How do I Set mailnews.pop3.loglevel to All

Found it. Well hidden.

The popstate.dat file may have been corrupted, but I deleted all the messages from the POP3 server except for the most recent new messages for the account. I also set my account to leave messages on the server for 14 days instead of until I delete them. So I won't be filing a bug report, since it hasn't reoccured.

I am curious to know if the reporter and doug2 are the same person.
Is the reporter satisfied that the issue is resolved?
Is Ernestas satisfied that the issue is resolved?

I know I am satisfied that the "Get Messages" function for POP accounts consistently shows the activity in the status bar, but am hesitant to verify the fix.

Flags: needinfo?(edinger)

Hello, this is Diane...I am the reporter.

Using b2, in most cases I have been successfully seeing status bar messages in b2....compared to nothing b1. However, I have been seing instances where Get Messages stops showing the expected messages in one of the accounts. Even if there are no messages to retrieve, there would still be at least two messages.........the server query string followed by the no new messages string. I would expect that to show with every invocation of the Get Messages function. However, I still need to pin down the repro steps that lead to that scenario.

I will look into it more today, but I could just file a new bug too....I am fine either way....

Flags: needinfo?(edinger)

...thanks for such a fast group of efforts on this bug! :-)

After I set the loglevel to All, the problem has not recurred. I've tried the menu Get Messages and F5 and several different sequences. Makes me think the logging has moved the problem or delayed the process so it works. I'll keep trying.

Attached file mailnewspop3.txt

Attached mailnews with errors. Problem appears to be connected to "Moved xx messages to yyyy"

(In reply to D. Edinger from comment #26)
xref bug 68727.

(In reply to Magnus Melin [:mkmelin] from comment #30)

(In reply to D. Edinger from comment #26)
xref bug 68727.

Wow...that's been around for quite some time.

Attached file mailnewspop3-b.txt

Overnight without downloading any mail. A few errors early, then hours of no apparent error.

Did the error file help? Do you want more? Do I need to create a new bug report?

Thanks, comment 29 is helpful, but I can't reproduce it. Yes, please try to find out a reliable way to reproduce and create a new bug report.

Flags: needinfo?(edinger)
Flags: needinfo?(dmccammishjr)
Keywords: steps-wanted

RE: comment 26 ...

I am suspecting that intermittent issue I was seeing in 99.0b2 might have been addressed in v100.0b1. If I am ever able to repro such a scenario again, I will create a new bug report as well. Thank you!

early AM, no download, no status change at F5 (fn-F5) Win 11, 64 bit, mailnews.pop3.loglevel ALL
used menu requested download, new mail arrived, status correct, no log?

You need to log in before you can comment on or make changes to this bug.