Closed Bug 1759911 Opened 2 months ago Closed 2 months ago

Exception... "Could not convert JavaScript argument arg 4 [nsIWebBrowserPersist.savePrivacyAwareURI]" nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS) after attempting to Save Page As on View Source window.

Categories

(Thunderbird :: Mail Window Front End, defect)

defect

Tracking

(thunderbird_esr91 wontfix)

RESOLVED FIXED
100 Branch
Tracking Status
thunderbird_esr91 --- wontfix

People

(Reporter: lasana, Assigned: lasana)

References

Details

Attachments

(1 file)

STR:

  1. Open a message.
  2. Click More > View Source.
  3. In the View Source Window, click File > Save Page As
  4. Wait for the dialog to come up and attempt to save the page.

Expected Result:
The contents of the message should be saved wherever you specified.

Actual Result:
Nothing saves, error is thrown in the console.

 [Exception... "Could not convert JavaScript argument arg 4 [nsIWebBrowserPersist.savePrivacyAwareURI]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: chrome://global/content/contentAreaUtils.js :: internalPersist :: line 497"  data: no] contentAreaUtils.js:497:13
    internalPersist chrome://global/content/contentAreaUtils.js:497
    continueSave chrome://global/content/contentAreaUtils.js:387
    internalSave chrome://global/content/contentAreaUtils.js:335

Looks like the cookiejar settings param is missing (we're trying to pass the document as cookiejarsettings). https://searchfox.org/comm-central/rev/99fb01a74eff1dae4430bd3b41a4c25abbb09708/mail/base/content/viewSource.js#128

Assignee: nobody → lasana

(In reply to Magnus Melin [:mkmelin] from comment #1)

Looks like the cookiejar settings param is missing (we're trying to pass the document as cookiejarsettings). https://searchfox.org/comm-central/rev/99fb01a74eff1dae4430bd3b41a4c25abbb09708/mail/base/content/viewSource.js#128

Thanks, I was confused looking at the nsIWebBrowserPersist.idl signature.

Status: NEW → ASSIGNED
Target Milestone: --- → 100 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/31042e4016bf
Add missing cookieJarSettings parameter to internalSave. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1756016
You need to log in before you can comment on or make changes to this bug.