Closed Bug 1760810 Opened 9 months ago Closed 9 months ago

Fix incorrect passes of WebGPU tests on Linux/Windows 7

Categories

(Core :: Graphics: WebGPU, task, P3)

task

Tracking

()

RESOLVED FIXED
100 Branch
Tracking Status
firefox100 --- fixed

People

(Reporter: aosmond, Assigned: aosmond)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Our tests are actually failing in CI on Ubuntu 18.04/Windows 7. We should catch the error in the tests so that it fails properly, and then mark these targets as failing in the mochitest config.

The WebGPU tests are actually failing silently on Ubuntu 18.04 and
Windows 7. This is because we catch the exception thrown in the async
function wrapping the test and then discard it at the end. Now if we
catch any errors, we fail the test, which requires us to mark these
tests as failing on some platforms.

Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/23d4033b2dce
Mark WebGPU tests as failing on Ubuntu 18.04 and Windows 7. r=gfx-reviewers,lsalzman
Regressions: 1761014
Regressions: 1761016
Regressions: 1761017
Regressions: 1761019
Regressions: 1761020
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
You need to log in before you can comment on or make changes to this bug.