Closed Bug 1768376 Opened 2 months ago Closed 1 month ago

Main menubar active color at win10

Categories

(Firefox :: Theme, defect)

Firefox 100
defect
Points:
2

Tracking

()

VERIFIED FIXED
102 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox100 --- wontfix
firefox101 --- verified
firefox102 --- verified

People

(Reporter: alstjr7375, Assigned: sfoster)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [fidefe-2022-mr1-css-linting])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:100.0) Gecko/20100101 Firefox/100.0

Steps to reproduce:

Hover or open main menubar's menu

  • Win10
  • Light theme (It works well in dark themes.)

Actual results:

Background color is -moz-menuhover

Expected results:

The following color should be applied.

 #main-menubar > menu[_moz-menuactive="true"],
.titlebar-button:hover {
  background-color: hsla(0,0%,0%,.12);
}

https://searchfox.org/mozilla-central/source/browser/themes/windows/browser-aero.css#186

The Bugbug bot thinks this bug should belong to the 'Firefox::Theme' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Theme

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:100.0) Gecko/20100101 Firefox/100.0

Hi,

I am able to reproduce the issue in release 100, beta 101 and the latest nightly 102.0a1 (2022-05-13) using Windows 10.
Here is the regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=f4823585e985134965ed14c18af62b57346625de&tochange=60f515867f95f47b025f1bb280c6332a9f394321

Thanks for the report.

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Keywords: regression
Regressed by: 1753767
Version: Firefox 101 → Firefox 100

:sfoster, since you are the author of the regressor, bug 1753767, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(sfoster)
Duplicate of this bug: 1769210

Possibly related to or a dupe of bug 1768380. I'm looking into this.

Flags: needinfo?(sfoster)
See Also: → 1768380
Assignee: nobody → sfoster
Status: NEW → ASSIGNED

Ok, I see what happened here. Prior to this patch, the rules from browser-aero.css were included close to the end of browser/themes/windows/browser.css: https://hg.mozilla.org/mozilla-central/file/4cb7108079fd542e3cfb1c8a8992fe837b917b72/browser/themes/windows/browser.css, and the converted that %include to an @import, and moved it to the top of the file. This had the effect that rules in browser.css would now supercede those with the same specificity defined in browser-aero.css

Specifically, we have a rule for firefox on windows generally that gives the active menu its color in browser.css:

#main-menubar > menu[_moz-menuactive="true"] {
  background-color: -moz-menuhover;
  color: -moz-menuhovertext;
}

And we have a rule in browser-aero.css which should override this:

#main-menubar > menu[_moz-menuactive="true"],
.titlebar-button:hover {
  background-color: hsla(0,0%,0%,.12);
}

This order got reversed, so the browser-aero.css rule is no longer applied in this case.

The severity field is not set for this bug.
:dao, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dao+bmo)

Sam, could we get that reviewed and landed before the merge? Thanks

Flags: needinfo?(sfoster)
Attachment #9277839 - Attachment description: Bug 1768376 - Restore previous order of aero-related rules by inlining browser-aero.css into windows/browser.css. r?Dao → WIP: Bug 1768376 - Restore previous order of aero-related rules by loading browser-aero.css for XP_WIN only from browser.xhtml. r?dao!
Attachment #9277839 - Attachment description: WIP: Bug 1768376 - Restore previous order of aero-related rules by loading browser-aero.css for XP_WIN only from browser.xhtml. r?dao! → Bug 1768376 - Restore previous order of aero-related rules by loading browser-aero.css for XP_WIN only from browser.xhtml. r?dao!

(In reply to Pascal Chevrel:pascalc from comment #10)

Sam, could we get that reviewed and landed before the merge? Thanks

I've just put a revised patch up for review, so I think this can happen - and my reviewer is also aware we want this landed before merge day.

Points: --- → 2
Flags: needinfo?(sfoster)
Flags: needinfo?(dao+bmo)
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/22b5dfe319e3
Restore previous order of aero-related rules by loading browser-aero.css for XP_WIN only from browser.xhtml. r=dao
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 102 Branch

The patch landed in nightly and beta is affected.
:sfoster, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(sfoster)

Comment on attachment 9277839 [details]
Bug 1768376 - Restore previous order of aero-related rules by loading browser-aero.css for XP_WIN only from browser.xhtml. r?dao!

Beta/Release Uplift Approval Request

  • User impact if declined: Colors of some elements like menus don't match expected theme colors
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment #0, this only affects some window configurations
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Restores previous CSS rule order, no functional changes
  • String changes made/needed: None
  • Is Android affected?: No
Flags: needinfo?(sfoster)
Attachment #9277839 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Thank you for fix bug!!

Comment on attachment 9277839 [details]
Bug 1768376 - Restore previous order of aero-related rules by loading browser-aero.css for XP_WIN only from browser.xhtml. r?dao!

Thanks for sorting this out. Approved for 101.0rc2.

Attachment #9277839 - Flags: approval-mozilla-beta? → approval-mozilla-release+

Verified - Fixed in latest Nightly 102.0a1 (build id: 20220525185636) and Fx101.0rc2 (build id: 20220525210143) using Windows 10.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Whiteboard: [fidefe-2022-mr1-css-linting]
Duplicate of this bug: 1768380
You need to log in before you can comment on or make changes to this bug.